AS300 Upgrade Tasks Summary—IMPAX 6.2 or later to IMPAX 6.5.1AGFA &

Running the Cross-Cluster
Dictation Interlock tool

1. On the 6.5.1 Application Server where the
Relay service is running, open a command
prompt.

2. Type the following command:
net start StudyStatusRelayService
3. Exit the command prompt.

Taking a system snapshot

1. At a command prompt, change to the
C:\mvf-mig6\bin directory.

2. Type

migration_inventory -d database_name
-U database_user_name -P
database_password -s -D
database_server_host_name

3. To create a report file with this information,
type
mig_reporter -t system_inventory_tool

Emptying Connectivity Manager
queues

1. In Connectivity Manager, open Service Tools
and click Queue Manager.

2. Select any device with either pending or
error transactions and empty the queues.

3. Retry recent messages and delete older
messages since newer transactions may
have updated patient, study, and report data
after these transactions entered an error
state.

Stopping Connectivity Manager
interfaces

1. In the Connectivity Manager, open Service
Tools.

2. To resort and group all device classes, click
Class.

3. Scroll down to view CMSI and HL7 class
devices.

4. Note which HL7 In and CMSI In interfaces
are started. These interfaces must be
restarted after the IMPAX upgrade.

5. Select the checkbox beside each of the
started inbound interfaces.

6. Click Stop.

Stopping Connectivity Manager
queues

1. In the Connectivity Manager, open Service
Tools and click Queue Manager.

2. Inthe Queue List table, select the checkbox
beside each queue belonging to a device
with a DM Out or impax_report_server
component.

3. Click Stop.

Stopping data transmission to
IMPAX 6.2 or later

1. Open the Windows Administrative Tools and
select Services.

2. Right-click the DICOM Service Class Provider
service and select Properties.

To change the Service status, click Stop.
From the Startup type list, select Disabled.
To close the Properties dialog, click OK.

A U A~ W

Launch the 6.2 or later Administration Tools
and log in as user service.

7. On the Daily tab, select Job Manager.

8. Monitor each Transmit queue and wait for
all outgoing jobs to finish.
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9. Select each Transmit queue and click Halt

Queue. @

10. To confirm that you want to halt the queue,
click Yes.

Verifying unverified studies

1. In the 6.2 or later Administration Tools, on
the Daily tab, click Study Manager. B

2. From the location list, select Failed
Verification.

3. Set other search criteria to Any value.

4. Click Refresh. %]

5. In the search results, select all studies.
6. To fix up the studies that have failed
HIS verification, click Fix All Studies. I@l

7. Review the results presented in the dialog.

Storing unarchived studies

1. In the 6.2 or later Administration Tools, on
the Daily tab, click Study Manager.

2. From the location list, select Cached (or
another value that will return the unarchived
studies).

3. Set other search criteria to Any value (or
set to appropriate values).

4. Click Refresh. %]

5. In the search results, select the studies to
archive.

6. Click Store to Archive. Iff'

7. To update the status of the selected studies,
click Refresh. ij

8. Ensure that all studies are archived.
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Closing and mirroring archive
volumes

1. In the 6.2 or later Administration Tools, on
the Setup tab, select Archive Manager.

a

2. Switch to the Volumes tab.

3. Select a logical volume and click Close
Logical Volume.

4. If the system has a jukebox archive, you
may have to wait for the sync job to finish.

If the system has a non-jukebox archive, to
ensure that a backup of the data exist,
perform a mirror procedure manually.

5. On the Daily tab, select Job Manager. 0

6. Check the Delivery Date Time column for
jobs that are not scheduled to run until later.
If any exist, schedule these jobs to complete
now, using the Set Delivery Date and
Time option at the top.

Emptying all queues

1. In the 6.2 or later Administration Tools, on
the Daily tab, select Job Manager.

2. If an archive job remains in any of the
gueues, select the job and click Expedite
Selected Job(s). of

3. If any other job remains in any of the
queues, select the job and click Delete
selected job(s). ﬂj%.

Halting all queues

1. In the Administration Tools, on the Daily
tab, select Job Manager. 0

2. In the queue list, select All Queues.
3. Click Halt Queue. @

4. To confirm that you want to halt the queues,
click Yes.

Stopping antivirus software

1. On a Windows server to upgrade, launch the

antivirus software.
2. Halt the scan operation according to the
vendor’s instructions.
Clearing the archive Logical
Volume

1. In the 6.2 or later Administration Tools, on
the Setup tab, select Archive Manager.

i

2. Select the Logical Volume and click Close.

3. At the Close Volume prompt, click Yes.

4. Ensure that the Archive queue is halted.

5. Delete the Logical Volume folder and files
from the drive.

Deleting old log files

1. On the server to be upgraded, open a
command prompt.

2. Change to the C:\mvf\bin\ directory.
3. Run stopall.bat.

4. For future reference, copy all files in
C:\mvf\data\logs\ to a backup location.

5. Delete all the log files from
C:\mvf\data\logs.

Recording the names of
previously installed IMPAX AS300
software packages

1. On the IMPAX 6.4 or later server, open
Control Panel.

N

Select Add or Remove Programs.

3. Select AGFA IMPAX AS300 and click
Change.

4. After the installer launches, click Modify.
5. Click Next.

© Copyright 2011 Agfa HealthCare N.V., Septestraat 27, B-2640, Mortsel, Belgium

14 June 2011

6. Make note of the installed packages.

To record the names of previously installed IMPAX 6.2
or 6.3 AS300 software packages

1. On the IMPAX 6.2 or 6.3 Windows server to
upgrade, select Start > Run.

2. In the Open field, type regedit and click
OK.

3. In the Registry Editor, select
HKEY_LOCAL_MACHINE\SOFTWARE\Mitra
Imaging Inc. and
HKEY_LOCAL_MACHINE\SOFTWARE\Mitra
and make note of the installed packages.

Upgrading to Windows 2008

Microsoft recommends doing a clean installation
of operating systems whenever possible.

For information regarding migration or upgrade
to Windows 2008:

http://technet.microsoft.com/en-us/library/
cc755199(WS.10).aspx

Also, consult the hardware vendor's website for
information about drivers.

Configuring Windows 2008

After upgrading, configure Windows 2008 as
follows:

e Activate Windows

e Set the Start menu and Control Panel to
Classic mode

e Change the page file setting, so the server
does not run out of virtual memory

e Support security certificate validation

o Partition disks appropriately for database,
volumes, logs, cache, and ghost

¢ Add the appropriate roles
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Details on these configurations are provided in
the IMPAX 6.5.1 AS300 Installation and
Configuration Guide.

Upgrading Windows Server 2008
to Windows Server 2008 SP2

1.

Connect to the network or computer where
you want to create the distribution folder.

In the shared folder, create a distribution
folder for the service pack.

Copy Windows6.0-KB948465-XXX.exe into
the distribution folder.

To install the service pack from a remote
shared distribution folder, run
Windows6.0-KB948465-XXX.exe.

5. Follow the instructions in the Setup Wizard.

6. When the installation process is complete,

restart the computer.

Enabling Automatic Updates in
Windows 2008

A W N =

v

Open Control Panel.
Select Windows Update.
Click Change Settings.

Select Download updates, but let me
choose whether to install them.

To apply the changes, click OK.

If you see the message To check for
updates, you must first install an
update for Windows Update, click Install
now.

To verify that the Automatic Updates service
is started, at a command prompt, type net
start.

Verify that Automatic Updates is included in
the list of services.

Enabling remote access to
Knowledge Bases

1.

In Internet Explorer, select Tools >
Internet Options.

In the Internet Options dialog, switch to the
Security tab.

3. Select Trusted sites.
4. Click Sites.

In the Trusted sites dialog, if you are
connecting to the Knowledge Base using
http:// rather than https://, clear the
Require server verification (https:) for
all sites in this zone checkbox.

In the Add this website to the zone field,
type or paste the name of the Application
Server that the Knowledge Bases are
installed on (https://server_name ).

7. Click Add.
8. Click Close.
9. Click Custom Level. In the Security

10.

Settings dialog, under Scripting, ensure that
Active scripting is enabled. Click OK.

Click OK.

Enabling local access to
Knowledge Bases

1.

In Internet Explorer, select Tools >
Internet Options.

In the Internet Options dialog, switch to the
Advanced tab.

Under Security, select the Allow active
content from CDs to run on My
Computer and the Allow active content
to run in files on My Computer
checkboxes. Click OK.

For the changes to take effect, close and
restart Internet Explorer.
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Manually backing up the SQL 2000
database

1.
2.

5.
6.

Open the SQL Server Enterprise Manager.

In the Explorer window of the Enterprise
Manager, expand Console Root

> Microsoft SQL Servers > SQL Server
Group > server > Databases >
database

. Select Action > All Tasks > Backup

database.

Configure the General and Options tabs
according to your preferences for items such
as the type of backup, the destination, and
whether to overwrite or append to the
media.

To start the backup, click OK.
Exit the SQL Server Enterprise Manager.

Upgrading SQL Server 2000 to
SQL Server 2008

1.

On the server you are upgrading, ensure
that the Distributed Transaction Coordinator
service is running:

a. Open the Windows Administrative
Tools and select Services.

b. Select the Distributed Transaction
Coordination service. If this service
is not started, click Start Service.

Ensure that the SQLSERVERAGENT service
is started.

. To launch the installer, follow the

instructions supplied with the SQL Server
2008 software.

When prompted, click OK and follow the
on-screen instructions to install the Microsoft
.NET Framework and updated Windows
Installer. You might be asked to restart the
server.

In the SQL Server Installation Center, select
Installation, then select Upgrade from
SQL Server 2000 or SQL Server 2005.
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6. On the Setup Support Rules screen, ensure
that all operations have completed
successfully. Click OK.

7. On the next screen, enter the product key.
Click Next.

8. When prompted, accept the Microsoft
Software License Terms. Click Next.

9. On the Setup Support Files screen, click
Install. After the support files are installed,
click Next.

10. On the Setup Support Rules screen, ensure
that all operations have completed
successfully. Click Next.

11. In the Select Instance screen, check that
Instance to Upgrade has been set to
MSSQLSERVER. Click Next.

12. On the Select Features screen, click Next.

13. On the Instance Configuration screen, click
Next.

14. Verify that the disk space requirements have
been met. Click Next.

15. On the Server Configuration screen, click
Next.

16. On the Full-text Upgrade screen, keep the
default and click Next.

17. On the Error and Usage Reporting screen,
click Next.

18. On the Upgrade Rules screen, check that no
errors appear. Click Next.

19. On the Ready to Upgrade screen, click
Upgrade.

20. Verify that the upgrade was successful, then
click Finish and Close.

21. Restart the computer.

Stopping SQL Server 2008
services

1. Open the Windows Administrative Tools.

2.

Select Services.

3. Select each of the following services in turn
and click Stop Service, if needed:

a. SQL Server Full Text Search

b. SQL Server Full Text Filter Daemon
Launcher

c. SQL Server Browser

d. SQL Server Integration Services
10.0

4. Close the Services window.

Upgrading SQL Server 2008 to
SQL Server 2008 SP1

1. Launch the SP1 installer.
If you see a security warning, click Run.

On the Welcome screen, click Next.

>N

On the License Terms screen, select I
accept the agreement. Click Next.

5. On the Feature Selection screen, accept the
default selections. Click Next.

6. On the Check Files in Use screen, wait while
the processes are identified. Then, click
Next, even if some locked files are found.

7. On the Ready to Update screen, click
Update.

8. On the Update Progress screen, wait until
the components are upgraded or installed,
then click Next.

9. If the Computer Reboot Required prompt
appears, click OK.

10. On the Installation Complete screen, click
Close.

11. Restart the computer.
Upgrading the IMPAX SQL Server
database schema to IMPAX 6.5.1
1. Open a command prompt.
2. Change to the C:\mvf-mig6\bin directory.
3. If upgrading from IMPAX 6.5, type
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database-upgrade-script.bat

If upgrading from IMPAX 6.2, 6.3, or 6.4,
type

database-upgrade-script.bat -v {62 |
63 | 64}

. At the prompt

Ready to upgrade database to version
6.5.1. Do you want to proceed [y,n]?

Verify that the version_number listed is
correct—for example, that it says 62 if

upgrading from IMPAX 6.2. If so, press
Enter to continue.

If the version is incorrect, type q and press
Enter, then repeat the previous step with
the correct version number specified.

. If prompted for a report source, in most

cases, type UNKNOWN.

If using a queryable RIS and multiple
Connectivity Managers, type the value used
for the Connectivity Manager issuer_of_*
and mcf_bls_report_workflow
domain_id fields.

. Respond appropriately to other prompts that

appear.

Checking the status of SQL Server
upgrades

1. Open the log file called

C:\mvf-mig6\data\logs\
migrate_database_to_IMPAX6.5.1.log

. If the following warning appears in the log

file, you can safely ignore it:

Warning: The table
"CHANGE_CONTEXT_DETAIL" has been
created but its maximum row size
(8095) exceeds the maximum number of
bytes per row (8060). INSERT or UPDATE
of a row in this table will fail if
the resulting row length exceeds 8060
bytes.
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3.

Ensure that Migration Complete
Successful appears at the end of the log
file.

Uninstalling the previous IMPAX
software packages

1.
2.
3.

Open Control Panel.
Select Add or Remove Programs.

Under Currently installed programs, select
Agfa IMPAX 6.2 version , Agfa

IMPAX 6.3 version , or Agfa

IMPAX AS300 (used for IMPAX 6.4 and
later).

Click Change/Remove.
or

For uninstalling IMPAX 6.4 and later, click
Remove.

When prompted, type your name (minimum
three characters). Click Next.

6. In the Confirmation dialog, click OK or Yes.

7. On the Maintenance Complete screen, click

8.

Finish.

Restart the server.

Upgrading the IMPAX AS300
32-bit Database Server software

1.
2.

Insert the IMPAX AS300 DVD.

Navigate to D:\programs\mvf and
double-click as300-installer.exe.

. Type your name (minimum three

characters).

On the Welcome screen, click Next.

5. On the Select features screen, all Default

Packages are selected. Clear the checkboxes
of any packages that should not be installed.

For a single-host server, install all default
packages except, potentially, the MVFocr
package. For a dedicated Database Server,
the MVFNetworkGateway package is not
required, but can be installed.

10.

11.

12.

13.

14.

15.

16.

Select the Database Packages label.

If upgrading under SQL Server, clear the
Oracle Server Extension checkbox and
select the SQL Server Extension checkbox.

If upgrading an IMPAX 6.4 or later Oracle
Database Server, confirm that the Oracle
Server Extension checkbox is selected.

For a dedicated Database Server (no
archive), or if using PACS Store and
Remember archiving only, clear the Archive
Packages checkbox.

Select the Optional Packages label, then
select the checkboxes of any optional
packages that should be installed.

Click Next.

If a Network Gateway package was installed,
browse to the location of the MVF license
file and click OK.

If an Archive package was installed, browse
to the location of the archive license file and
click OK.

When prompted, type the password for the
AgfaService user.

To confirm that the database is compatible,
click Yes.

On the Ready to begin installation screen,
click Next.

To display the log file for the database
scripts, when prompted, click No.

After all the packages have been installed,
click Yes, I want to restart my computer
now.

Generating the AS300 portable
password file

1.

On the Database Server, open a command
prompt.

2. Change to the C:\mvf\bin\ directory.
3. Type
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passkey -M EXPORT -k
temporary_password

Updating the SQL Server
registration

1.

2.

Select Start > All Programs > Microsoft
SQL Server 2008.

Right-click SQL Server Management
Studio and select Run as.

In the Run as dialog, select The following
user.

. From the User name list, select

AgfaService.

In the Password field, type the password for
the AgfaService account and click OK.

Applying patches and upgrading
Oracle

1.

Log into the Database Server as the
Administrator.

Insert either the Oracle on Windows 32-bit
DVD or the Oracle on Windows 64-bit DVD,
depending on the version of Windows
running on the server.

3. Open a command prompt.

4. Change to the c:\mvf-mig6\bin directory.

5. Type

bash upgrade-oracle
location_of _DVD_drive_or_Oracle_software_
repository

If the upgrade-oracle script aborts, it could
be the due to permission problems.

. At the prompt Ready to upgrade Oracle

using repository <Oracle software
location>. Do you want to proceed?

Ly/n]

Verify the Oracle software location. If the
location is correct, type y and press Enter.

or
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If an Oracle Data Guard configuration is
detected, you are prompted to continue the
upgrade on the primary (or standby) server.
Type y and press Enter.

Upgrading the IMPAX Oracle
database schema to IMPAX 6.5.1

1.
2.
3.

Open a command prompt.

Change to the C:\mvf-mig6\bin directory.
Type

oracle-database-upgrade.bat

. At the prompt Ready to upgrade

database. Do you want to proceed
[y.n]?, type y and press Enter.

Checking the status of Oracle
upgrades

1.

2.

Navigate to the C:\mvf-mig6\data\logs
directory.

Open the database_upgrade.log file.

3. Ensure that Migration Complete

Successful appears at the end of the log
file.

If this message does not appear, review the
rest of the log file to see where the upgrade
failed. Solve the problem, then rerun the
upgrade script.

Uninstalling the previous IMPAX
software packages

1.
2.
3.

Open Control Panel.
Select Add or Remove Programs.

Under Currently installed programs, select
Agfa IMPAX 6.2 version , Agfa

IMPAX 6.3 version , or Agfa

IMPAX AS300 (used for IMPAX 6.4 and
later).

Click Change/Remove.
or

For uninstalling IMPAX 6.4 and later, click
Remove.

When prompted, type your name (minimum
three characters). Click Next.

6. In the Confirmation dialog, click OK or Yes.

7. On the Maintenance Complete screen, click

8.

Finish.

Restart the server.

Upgrading the IMPAX AS300
32-bit or 64-bit Oracle Data Guard
Database Server software

1.
2.

Insert the IMPAX AS300 DVD.

Navigate to D:\programs\mvf and
double-click as300-installer.exe.

. Type your name (minimum three

characters).

On the Welcome screen, click Next.

5. On the Select features screen, all Default

Packages are selected. Clear the
MVFNetworkGateway checkbox and any
other packages that are not required.

. Select the Database Packages label.

Confirm that the Oracle Server Extension
checkbox is selected.

7. Clear the Archive Packages checkbox.

8. Select the Optional Packages label, then

10.

11.

12.

13.

14.

select the MVForadg checkbox. All other
checkboxes should be cleared.

Click Next.

When prompted, type the password for the
AgfaService user.

To confirm that the database is compatible,
click Yes.

On the Ready to begin installation screen,
click Next.

To display the log file for the database
scripts, when prompted, click Yes.

Check the log files for errors, then close the
log files.
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15.

16.

17.

18.

After all the packages have been installed,
click Yes, I want to restart my computer
now.

When the computer restarts, log into
Windows as an administrator-level user.

On both the primary and standby servers,
restore the following files:

C:\oracle\product\10.2.0\db_1\NETWORK\
ADMIN\listener.ora.dg65

C:\oracle\product\10.2.0\db_1\NETWORK\
ADMIN\tnsnames.ora.dg65

Rename the new tnsnames.ora to
tnsnames.ora.new, then restore the
tnsnames.ora and the listener.ora files.

Upgrading the IMPAX AS300
32-bit Database Server software

1.
2.

Insert the IMPAX AS300 DVD.

Navigate to D:\programs\mvf and
double-click as300-installer.exe.

. Type your name (minimum three

characters).
On the Welcome screen, click Next.

On the Select features screen, all Default
Packages are selected. Clear the checkboxes
of any packages that should not be installed.

For a single-host server, install all default
packages except, potentially, the MVFocr
package. For a dedicated Database Server,
the MVFNetworkGateway package is not
required, but can be installed.

Select the Database Packages label.

If upgrading under SQL Server, clear the
Oracle Server Extension checkbox and
select the SQL Server Extension checkbox.

If upgrading an IMPAX 6.4 or later Oracle
Database Server, confirm that the Oracle
Server Extension checkbox is selected.

. For a dedicated Database Server (no

archive), or if using PACS Store and
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10.

11.

12.

13.

14.

15.

16.

Remember archiving only, clear the Archive
Packages checkbox.

Select the Optional Packages label, then
select the checkboxes of any optional
packages that should be installed.

Click Next.

If a Network Gateway package was installed,
browse to the location of the MVF license
file and click OK.

If an Archive package was installed, browse
to the location of the archive license file and
click OK.

When prompted, type the password for the
AgfaService user.

To confirm that the database is compatible,
click Yes.

On the Ready to begin installation screen,
click Next.

To display the log file for the database
scripts, when prompted, click No.

After all the packages have been installed,
click Yes, I want to restart my computer
now.

Upgrading a dedicated 64-bit
IMPAX AS300 Database Server

1.
2.

Insert the IMPAX AS300 DVD.

Navigate to D:\programs\mvf and
double-click as300-installer-64.exe.

. Type your name (minimum three

characters).

4. On the Welcome screen, click Next.

5. On the Select features screen, the

appropriate packages are already selected,
so click Next.

On the Type of Install screen, select Use an
existing database and click Next.

Click Install.

8.

After all the packages have been installed,
click Yes, I want to restart my computer
now.

Generating the AS300 portable
password file

1.

On the Database Server, open a command
prompt.

2. Change to the C:\mvf\bin\ directory.
3. Type

passkey -M EXPORT -k
temporary_password

Determining the version of the
installed Oracle Client

1.
2.

Open a command prompt.
Type
sqlplus -V

Uninstalling the previous version
of Oracle Client

1.

Select Start > All Programs > Oracle -
ohome > Oracle Installation Products
> Universal Installer.

2. Click Deinstall Products.

3. Inthe Inventory dialog on the Contents tab,

select the OraClient10_homel checkbox,
where homel can be any text.

Click Remove.

5. In the Confirmation dialog, to confirm the

uninstall, click Yes.

. After the uninstall is complete, to close the

Universal Installer, click Close, then Cancel.

Open the Windows Administrative Tools and
select Services.

Select the Distributed Transaction
Coordinator service. If it started, click Stop
to stop it.

From Windows Explorer, delete the
drive_letter:\oracle directory.
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10.

11.

12.

From Windows Explorer, delete the
C:\Program Files\Oracle directory.

Run regedit and delete the
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE
key.

Restart the computer.

Installing and configuring the
Oracle 10g Client for Windows

1.

Insert the IMPAX Oracle for Windows 32-bit
DVD.

2. From the DVD drive, run setup.bat.

3. At the Install Oracle "client” or

“server"? prompt, type client.

. At the Hostname of the Oracle server

[1 ? prompt, type the correct host name of
the IMPAX Database Server.

. At the What machine is the repository

host? [localhost] prompt, if it is the
localhost, press Enter. Otherwise, specify
the appropriate IP address.

. At the Where is the software

repository? prompt, if installing from the
DVD drive on F, press Enter. Otherwise,
type the DVD drive or software repository
directory.

. At the Where is the temporary work

directory? [ C:\cygwin\temp] ? prompt,
click Enter to accept the default location.
Otherwise, type the directory to use.

. After the Oracle installation complete

message appears, restart the server.

Upgrading to the 10.2.0.4 version
of the Oracle Client for Windows

1.

P w N

Insert the Oracle on Windows 32-bit DVD.
Open a command prompt.
Change to the C:\mvf-mig6\bin directory.

Type bash upgrade-oracle
location_of_DVD_drive_or
_Oracle_software_repository
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5.

When you see the message Ready to
upgrade Oracle using repository Oracle
software location. Do you want to
proceed? [y/n], verify that the oracle
software location is correct. If the location
is correct, type y and press Enter.

Reconfiguring ODBC data source
names

1.

i wWnN

© © N o

10.
. To save the changes and close the dialog,

12.

13.

Open the Windows Administrative Tools.
Select Data Sources (ODBC).

Switch to the System DSN tab.

Click Add.

In the Create New Data Source dialog, select
Oracle in Oracle_instance_name

Click Finish.
In the Data Source Name field, type mvf.
Type a description, if needed.

In the TNS Service Name field, type
MVF.world.

In the User Name field, type mvf.

click OK.

To save the new sources and exit the ODBC
Data Source Administrator dialog, click OK.

If reconfiguring the Application Server,
repeat the previous steps for the mvf_ora
DSN as well.

Backing up the AS300 SQL 2000
database

1.

On the server running the AS300 database,
select Start > All Programs > Microsoft
SQL Server > Enterprise Manager.

In the Explorer window of the Enterprise
Manager, expand Console Root >

Microsoft SQL Servers > SQL Server
Group > server > Databases > MVF

Select Action > All Tasks > Backup
database.

6.
7.

In the SQL Server Backup screen, in the
Backup section, select
Database-complete.

Click Add and specify the directory to back
up to.

To start the backup, click OK.
Exit the SQL Server Enterprise Manager.

Manually backing up the SQL
database

1.

7.
8.

Select Start > All Programs > Microsoft
SQL Server.

Right-click SQL Server Management
Studio and select Run as.

Select The following user. Type
AgfaService as the user name, and the
AgfaService password.

In the Object Explorer window, expand
server > Databases > database_name

Right-click database_name and select
Tasks > Backup.

Configure the General and Options tabs
according to your preferences for items such
as the type of backup, the destination, and
whether to overwrite or append to the
media.

To start the backup, click OK.
Exit the SQL Server Management Studio.

Restoring the upgraded database
on a new Database Server

1.

Before starting the restore, confirm that the
directory that will contain the mvf database
files has the correct permission:

a. In Windows Explorer, right-click the
folder and select Properties.

Switch to the Security tab.

Click Edit.

Click Add.

Select ImpaxSQLUser and click OK.

P e o T
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f. Grant Full Control to ImpaxSQLUser
and click OK.

g. To close the Properties dialog, click
OK.

If you are restoring from tape, insert the
backup tape into the tape drive.

In the Explorer window of the SQL Server
Management Studio, expand server >
Databases.

. Right-click Database and select Restore

Database.

. In the Destination for restore section, in the

To database field, type mvf.

In the Source for restore section, select
From device and specify the backup media
and location.

. Under Backup set to restore backup set,

select the mvf database backup set.
Switch to the Options tab.

9. In the Restore the database files section,

10.

11.

12.

change the location of the data files as
needed.

Select Leave database ready to use by
rolling back uncommitted transactions.
Additional transaction logs cannot be
restored. Click OK.

Create the mvf user login:
a. Open SQL Server Management Studio.
b. Select Server > Security.

c. Right-click Logins and select New
login.

d. In the Login name field, type mvf.

e. Select SQL Server authentication
and in the Password field, type mvf.

f. Clear the Enforce password policy
checkbox and click OK.

Restore the mvf user permissions:

a. Open SQL Server Management Studio.
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b. Open a new query window.

c. Select File > Open and browse to
C:\mvf\etc.

d. Select recreate_user_mvf.sql and
click Open.

e. To execute the script, press F5 or click
Execute.

Upgrading the IMPAX SQL Server
database schema to IMPAX 6.5.1

1.
2.
3.

Open a command prompt.

Change to the C:\mvf-mig6\bin directory.
If upgrading from IMPAX 6.5, type
database-upgrade-script.bat

If upgrading from IMPAX 6.2, 6.3, or 6.4,
type

database-upgrade-script.bat -v {62 |
63 | 64}

. At the prompt

Ready to upgrade database to version
6.5.1. Do you want to proceed [y,n]?

Verify that the version_number listed is
correct—for example, that it says 62 if

upgrading from IMPAX 6.2. If so, press
Enter to continue.

If the version is incorrect, type q and press
Enter, then repeat the previous step with
the correct version number specified.

If prompted for a report source, in most
cases, type UNKNOWN.

If using a queryable RIS and multiple
Connectivity Managers, type the value used
for the Connectivity Manager issuer_of_*
and mcf_bls_report_workflow
domain_.id fields.

Respond appropriately to other prompts that
appear.

Checking the status of SQL Server
upgrades

1.

Open the log file called
C:\mvf-mig6\data\logs\
migrate_database_to_IMPAX6.5.1.log

If the following warning appears in the log
file, you can safely ignore it:

Warning: The table
"CHANGE_CONTEXT_DETAIL" has been
created but its maximum row size
(8095) exceeds the maximum number of
bytes per row (8060). INSERT or UPDATE
of a row in this table will fail if
the resulting row length exceeds 8060
bytes.

Ensure that Migration Complete
Successful appears at the end of the log
file.

Generating the AS300 portable
password file

1.

On the Database Server, open a command
prompt.

2. Change to the C:\mvf\bin\ directory.
3. Type

passkey -M EXPORT -k
temporary_password

Overview of upgrading an IMPAX
6.5 Database Server to
IMPAX 6.5.1

If the existing IMPAX 6.5 Database Server has an
adequate hardware profile, you can upgrade it to
IMPAX 6.5.1, saving on the cost of new hardware.
Follow these steps:

1.

Upgrade the SQL Server database schema
and then check the status of the upgrade.

or

Upgrade the Oracle database schema and
then check the status of the upgrade.
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2.

Uninstall the previous IMPAX software
package.

Upgrade the IMPAX Oracle Data Guard
Database Server software.

or

Upgrade the IMPAX AS300 32-bit Database
Server software.

or

Upgrade a dedicated 64-bit IMPAX AS300
Database Server.

Upgrading the IMPAX SQL Server
database schema to IMPAX 6.5.1

1.
2.
3.

4,

Open a command prompt.

Change to the C:\mvf-mig6\bin directory.
If upgrading from IMPAX 6.5, type
database-upgrade-script.bat

If upgrading from IMPAX 6.2, 6.3, or 6.4,
type

database-upgrade-script.bat -v {62 |
63 | 64}

At the prompt

Ready to upgrade database to version
6.5.1. Do you want to proceed [y,n]?

Verify that the version_number listed is
correct—for example, that it says 62 if

upgrading from IMPAX 6.2. If so, press
Enter to continue.

If the version is incorrect, type q and press
Enter, then repeat the previous step with
the correct version number specified.

If prompted for a report source, in most
cases, type UNKNOWN.

If using a queryable RIS and multiple
Connectivity Managers, type the value used
for the Connectivity Manager issuer_of_*
and mcf_bls_report_workflow
domain_id fields.
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6. Respond appropriately to other prompts that
appear.

Checking the status of SQL Server
upgrades

1. Open the log file called
C:\mvf-mig6\data\logs\
migrate_database_to_IMPAX6.5.1.log

2. If the following warning appears in the log
file, you can safely ignore it:

Warning: The table
"CHANGE_CONTEXT_DETAIL" has been
created but its maximum row size
(8095) exceeds the maximum number of
bytes per row (8060). INSERT or UPDATE
of a row in this table will fail if
the resulting row length exceeds 8060
bytes.

3. Ensure that Migration Complete
Successful appears at the end of the log
file.

Upgrading the IMPAX Oracle
database schema to IMPAX 6.5.1
1. Open a command prompt.
2. Change to the C:\mvf-mig6\bin directory.
3. Type
oracle-database-upgrade.bat

4. At the prompt Ready to upgrade
database. Do you want to proceed
[y.n]?, type y and press Enter.

Checking the status of Oracle
upgrades
1. Navigate to the C:\mvf-mig6\data\logs
directory.
2. Open the database_upgrade.log file.

3. Ensure that Migration Complete
Successful appears at the end of the log
file.

4. If this message does not appear, review the
rest of the log file to see where the upgrade
failed. Solve the problem, then rerun the
upgrade script.

Uninstalling the previous IMPAX
software packages

1. Open Control Panel.

2. Select Add or Remove Programs.

3. Under Currently installed programs, select
Agfa IMPAX 6.2 version , Agfa
IMPAX 6.3 version , or Agfa
IMPAX AS300 (used for IMPAX 6.4 and
later).

4. Click Change/Remove.
or

For uninstalling IMPAX 6.4 and later, click
Remove.

5. When prompted, type your name (minimum
three characters). Click Next.

6. In the Confirmation dialog, click OK or Yes.

7. On the Maintenance Complete screen, click
Finish.

8. Restart the server.

Upgrading the IMPAX AS300
32-bit or 64-bit Oracle Data Guard
Database Server software

1. Insert the IMPAX AS300 DVD.

2. Navigate to D:\programs\mvf and
double-click as300-installer.exe.

3. Type your name (minimum three
characters).

4. On the Welcome screen, click Next.

5. On the Select features screen, all Default
Packages are selected. Clear the
MVFNetworkGateway checkbox and any
other packages that are not required.

6. Select the Database Packages label.
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Confirm that the Oracle Server Extension
checkbox is selected.

7. Clear the Archive Packages checkbox.

8. Select the Optional Packages label, then
select the MVForadg checkbox. All other
checkboxes should be cleared.

9. Click Next.

10. When prompted, type the password for the
AgfaService user.

11. To confirm that the database is compatible,
click Yes.

12. On the Ready to begin installation screen,
click Next.

13. To display the log file for the database
scripts, when prompted, click Yes.

14. Check the log files for errors, then close the
log files.

15. After all the packages have been installed,
click Yes, I want to restart my computer
now.

16. When the computer restarts, log into
Windows as an administrator-level user.

17. On both the primary and standby servers,
restore the following files:

C:\oracle\product\10.2.0\db_1\NETWORK\
ADMIN\listener.ora.dg65

C:\oracle\product\10.2.0\db_1\NETWORK\
ADMIN\tnsnames.ora.dg65

18. Rename the new tnsnames.ora to
tnsnames.ora.new, then restore the
tnsnames.ora and the listener.ora files.

Upgrading the IMPAX AS300
32-bit Database Server software
1. Insert the IMPAX AS300 DVD.

2. Navigate to D:\programs\mvf and
double-click as300-installer.exe.

3. Type your name (minimum three
characters).
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4. On the Welcome screen, click Next.

Upgrading a dedicated 64-bit
IMPAX AS300 Database Server

Configuring the ODBC connection
to the SQL Database Server

5. On the Select features screen, all Default

Packages are selected. Clear the checkboxes

of any packages that should not be installed 1. Insert the IMPAX AS300 DVD. 1. On the server to connect, open the Windows
_ _ ) 2. Navigate to D:\programs\mvf and Administrative Tool and select Data
For a single-host server, install all default double-click as300-installer-64.exe Sources (ODBC).
packages except, potentially, the MVFocr o ) 2. Switch to the Svstem DSN tab.
package. For a dedicated Database Server, 3. Type your name (minimum three _ y
the MVFNetworkGateway package is not characters). 3. Click Add.
required, but can be installed. 4. On the Welcome screen, click Next. 4. Inthe Create New Data Source dialog, select
6. Select the Database Packages label. 5. On the Select features screen, the SQL Server.
If upgrading under SQL Server, clear the appr_opriate packages are already selected, 5. Click Finish.
Oracle Server Extension checkbox and so click Next. 6. In the Name field, type mvf.
select the SQL Server Extension checkbox. 6. On the Type of Install screen, select Use an o
. . - 7. In the Description field, type mvf.
If upgrading an IMPAX 6.4 or later Oracle existing database and click Next. .
Database Server, confirm that the Oracle 7. Click Install. 8. In the Server list, type or select the
Server Extension checkbox is selected. _ Database Server name. Click Next.
7 F dedicated Datab s 8. After all the packages have been installed, 9. If asked whether to overwrite the existing
- For a dedicated Database Server (no click Yes, I want to restart my computer : .
archive), or if using PACS Store and now. MVF_SQL, click Yes.
Remember archiving only, clear the Archive 10. Select the SQL Server Authentication
Packages checkbox. Uninstalling the previous IMPAX option.

8. Select the Optional Packages label, then software packages 11. In the Login ID and Password fields, type
select the checkboxes of any optional 1. Open Control Panel. the username and password for the mvf
packages that should be installed. user

o. Click N 2. Select Add or Remove Programs. :

. Click Next. . . - .
_ 3. Under Currently installed programs, select 12. Click Client Configuration.
10. If a Network Gateway package was installed, Agfa IMPAX 6.2 version , Agfa 13. In the Add Network Library Configuration
browse to the location of the MVF license IMPAX 6.3 version , or Agfa dialog, select TCP/IP. Click OK.
file and click OK. IMPAX AS300 (used for IMPAX 6.4 and .
. . later) 14. Click Next.
11. If an Archive package was installed, browse :
to the location of the archive license file and 4. Click Change/Remove. 15. Select the Change the default database
click OK. to checkbox.
or . .
12. When prompted, type the password for the For uninstalling IMPAX 6.4 and later, click 16. From the list, select mvF. Click Next.
Agfaservice user. Remove. 9 ' ' 17. Clear the Perform translation for
13. To confirm that the database is compatible, 5. When prompted, type your name (minimum character data checkbox.
click Yes. . ’ . -
o g ) | three characters). Click Next. 18. Click Finish.
14. On the Ready to begin installation screen, ; ;
click Next Y 9 6. In the Confirmation dialog, click OK or Yes. 19. To test the connection, click Test
' ) ] Connection.
15. To display the log file for the database 7 ?,r;,t:,f Maintenance Complete screen, click 20. In the ODBC Driver Connect dialog, type the
scripts, when prompted, click No. ' password for the mvf user and click OK.
16. After all the packages have been installed, 8. Restart the server. 21. When prompted that the connection was

click Yes, I want to restart my computer
now.
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22. To close the Oracle ODBC Driver
Configuration dialog, click OK.

23. To close the ODBC Data Source
Administrator window, click OK.

Installing the IMPAX 6.5.1 AS300
Network Gateway and Archive
Server packages

1. Insert the IMPAX AS300 DVD.

2. Navigate to D:\programs\mvf and
double-click as300-installer.exe.

3. Type your name (minimum three
characters).

4. On the Welcome screen, click Next.

5. On the Select features screen, all Default
Packages are selected. Clear the checkboxes
of any packages that should not be installed.

6. Clear the Database Packages checkbox.

7. For Archive Servers, select the Archive
Package label. The MVFhsm is the only
archive package listed and is selected by
default. If not using an HSM archive, clear
the MVFhsm checkbox; otherwise, keep it
selected.

For dedicated Network Gateway servers,
clear the Archive Packages checkbox.

8. Select the Optional Packages label.

9. Select any optional packages that should be
installed, and clear the other checkboxes.

10. Click Next.

11. If installing a Network Gateway or Archive
Server/Network Gateway combination,
browse to the location of the MVF license
file and click OK.

12. If installing an Archive Server or Archive
Server/Network Gateway combination,
browse to the location of the MVF archive
license file and click OK.

13. Browse to the location of the portable
password file and click OK.

14. Type the temporary password used to create
the portable password file and click Next.

15. On the Summary screen, click Next.

16. After all the packages have been installed,
click Yes, I want to restart my computer
now.

Installing and configuring Store
and Remember archiving

Some sites may want to have their studies
mirrored at another site through PACS Store and
Remember archiving. This mirroring protects
against loss of data and allows studies from one
PACS to be viewed at another. This can be
achieved effectively using the PACS Archive
Provider (PAP).

For instruction on installing and configuring a
PACS Archive Provider, refer to “Configuring a
PACS Archive Provider (PAP)” (topic number
11586) in the IMPAX 6.5.1 AS300 Installation
and Configuration Guide.

Upgrading the Curator

All dedicated Curator stations need upgrading.
Upgrade the master Curator first, by uninstalling
the existing IMPAX software, then installing the
IMPAX 6.5.1 AS300 software with the MVFCore,
possibly MVFCache, MVFCurator, and MVFcdexport
packages selected. Then upgrade all slave
Curators in much the same way, except that the
MVFcdexport package only has to be included on
one of the slave Curators.

Uninstalling the previous IMPAX
software packages

1. Open Control Panel.

2. Select Add or Remove Programs.

3. Under Currently installed programs, select
Agfa IMPAX 6.2 version , Agfa
IMPAX 6.3 version , or Agfa
IMPAX AS300 (used for IMPAX 6.4 and
later).

4. Click Change/Remove.
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or

For uninstalling IMPAX 6.4 and later, click
Remove.

5. When prompted, type your name (minimum
three characters). Click Next.

6. In the Confirmation dialog, click OK or Yes.

7. On the Maintenance Complete screen, click
Finish.

8. Restart the server.

Installing the Curator and CD
Export server software

1. Insert the IMPAX AS300 DVD.

2. Navigate to D:\programs\mvf and
double-click as300-installer.exe.

3. Type your name (minimum three
characters).

On the Welcome screen, click Next.
Clear the Database Packages checkbox.

Clear the Archive Packages checkbox.

No vk

Select the Optional Packages label and
select the appropriate packages.
MVFCurator must stay selected.
MVFcdexport is also required except,
perhaps, on slave Curators.

8. Click Next.

9. Browse to the location of the portable
password file and click OK.

10. Type the temporary password used to create
the portable password file and click Next.

11. On the Summary screen, click Next.

12. After all the packages have been installed,
click Yes, I want to restart my computer
now.
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Migrating the master Curator from
an all-in-one server to a separate
server

1.

10.

Log into the master Curator
machine—currently, the all-in-one server.

After all current Curator jobs have
completed, in the Job Manager, halt the
Curator job queue.

Install the Curator on a new machine by
following the instructions in the Curator and
CD Export Server Installation Guide.

Log into the new Curator server and start
IMPAX services.

To ensure that the new Curator’s ae_ref is
recorded in the database, open an SQL
editor an run the following query:

select * from map_ae where
ae_title=New __Curator_ae__title.

In CLUI, display a list of services by typing
the following:

service query

Using the results from the previous query,
find the service_ref for the service with the
appropriate values.

In CLUI, obtain the Curator queue_ref value
by typing the following:

queue query

Change the Master Curator service to the
Curator installed on the new machine by
running the following SQL Update
statement:

update map_queue set
service_ref=new_Curator_service_ref
where QUEUE_REF=Curator_queue_ref

Change ownership of the web cache to the
new master Curator by running the following
updated statement:

update osr_volume set
ae_ref=new_Curator ae_ref where

11.

12.

13.
14.

15.

16.

17.

ae_ref=o0ld_curator ae_ref and
volume_type="W"

Change the ae_ref values for all studies
located in the web cache by running the
following update statement:

update dosr_study_location set ae_ref
=new_curator_ae_ref where
ae_ref=o0ld_curator_ae_ref and
volume_type="W'" and study_ref >
a_study_ref and study_ref <=
another_study_ref.

Restart the Curator and Autopilot on the old
and new Curator machines.

Restart the Curator queues.

Check in the master Curator log file to see
if the following message appears:

If you have decided to leave the former
Master Curator as the slave Curator, test
that both Curators are running by following
these steps:

a. On the slave Curator machine, stop
the Mitra Task Scheduler process and
the Curator.

b. Send a test study and check that the
study is curated.

c. Restart the Mitra Task Scheduler
process and the Curator.

d. Restart the Curator queue on the
master Curator.

e. Ensure that both Curators and the
Mitra Task Scheduler are running.

If you have decided that the new Curator
(the Master Curator) will be the only
Curator, test that it works by sending a test
study. Check that the images were curated.

If you have decided to remove the former
Curator (the slave Curator), remove the
Curator service. b
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Removing the Curator service
from the slave Curator

1.

Log into the server whose service you want
to remove.

Ensure that all of the service’s jobs have
completed.

3. Using the Job Manager, halt all the queues.
4. Stop all IMPAX services.

On Windows 2003 server, open Control
Panel and select Add Remove Programs.

or

On Windows 2008 server, open Control
Panel and select Programs and Features.

6. Uninstall IMPAX.
7. To use this server with other IMPAX

10.

services, reinstall IMPAX and exclude the
Curator service from the installation.

. After the IMPAX installation is complete,

restart the IMPAX services.

Open CLUI and remove the service_ref of
the removed service by typing:

service delete service_ref

Restart all queues.

Migrating a cache volume from a
flat to a hierarchical structure

1.

At a command prompt on the system where
the cache volume is local, type

cache_migration.exe parameters
(Windows)

or

cache-migration parameters (Solaris,
logged in as mvf user)

Upgrading the Application Server
from a previous version

Upgrade all Application Servers in the cluster to
IMPAX 6.5.1.
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Upgrading the ADAM database

If you are upgrading a cluster to Windows Server
2008, you must replicate the ADAM database
instance on a new Windows 2008 server, which
uses the AD LDS database.

Backing up the ADAM database

1.

Select Start > All Programs >
Accessories > System Tools > Backup.

Select Tools > Options.

3. Switch to the Exclude Files tab.

In the list of file names, select C:\Program
Files\Microsoft ADAM and click Remove.
Click OK.

When the Backup or Restore Wizard is
displayed, clear the Always start in
Wizard mode checkbox and click
Advanced Mode.

On the Welcome screen, click Backup
Wizard.

7. On the Backup Wizard screen, click Next.

8. On the What to Backup screen, select

10.

11.

Backup selected files, drives, or
network data. Click Next.

On the Items to Backup screen, select the

folder containing the ADAM data as well as
the World Wide Web Publishing Service
folder. Click Next.

If backing up to a tape drive, under Backup
media type, select the tape drive, and in the
backup media area, click New media. Click
Next.

or

If backing up to any other media type, select
the location where the backup is to be
saved, and type a name for the backup.
Click Next.

On the Completing the Backup Wizard
screen, click Advanced.

12.

13.

14.

15.

16.
17.

On the Type of Backup screen, select
Normal. Click Next.

On the How to Backup screen, select Verify
data after backup and Use hardware
compression if available. Click Next.

On the Backup Options screen, select
Replace the existing backups. Click Next.

On the When to Backup screen, select Now.
Click Finish.

In the Backup Progress dialog, click Close.
Close the Backup Utility.

Stopping services on the
Application Servers

1.

On an Application Server, open the Windows
Administrative Tools and select Services.

In the list of services, highlight the World
Wide Web Publishing Service.

Click Stop.

4. Repeat steps 2 and 3 for the following

services:

a. IMPAX Distributed License
Manager

IMPAX Messaging Service
IMPAX App Server Data Manager
IMPAX Audit Event Log Manager
IMPAX Dicom Object Sender
AGFA HealthCare Service

-~ 0 a o T

Uninstalling IMPAX 6.2
documentation

1.
2.
3.

Open Control Panel.
Select Add or Remove Programs.

Under Currently installed programs, select
IMPAX 6.2 Documentation.

Click Change/Remove.

5. In the Confirmation dialog, click OK.
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In the Maintenance Complete dialog, click
Finish.

. Under Currently installed programs, select

IMPAX Application Server Knowledge
Base.

Click Change/Remove.

9. In the Confirmation dialog, click OK.

10.

11.

12.
13.
14.

15.

16.
17.
18.

In the Maintenance Complete dialog, click
Finish.

Under Currently installed programs, select
Impax Client Knowledge Base.

Click Change/Remove.
In the Confirmation dialog, click OK.

In the Maintenance Complete dialog, click
Finish.

Under Currently installed programs, select
IMPAX Server Knowledge Base.

Click Change/Remove.
In the Confirmation dialog, click OK.

In the Maintenance Complete dialog, click
Finish.

Uninstalling IMPAX 6.3 or later
documentation

1.
2.

4.
5.
6.

Open Control Panel.

In Windows 2008 Service Pack 2, select
Programs and Features.

In the Programs and Features dialog, under
Currently installed programs, select AGFA
IMPAX version Knowledge Base
buildnumber Documentation.

Click Remove.
In the confirmation dialog, click OK.

Close the Programs and Features dialog.

Uninstalling the IMPAX
Installation Server

1.

Open Control Panel.
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2. In Windows 2008 Service Pack 2, select
Programs and Features.

3. Select Agfa IMPAX Installation Server
version_number where version_number
is the version of the installed Installation
Server.

4. Right-click and select Uninstall.
Determining the version of the
installed Oracle Client

1. Open a command prompt.

2. Type

sqlplus -V
Removing ODBC entries prior to
uninstalling the Oracle Client

1. Open the Windows Administrative Tools and
select Data Sources (ODBC).

2. In the ODBC Data Source Administrator
screen, select the System DSN tab.

3. For each driver listed, select the associated
name and click Remove.

4. Click OK.

Uninstalling the previous version
of Oracle Client

1. Select Start > All Programs > Oracle -
ohome > Oracle Installation Products
> Universal Installer.

2. Click Deinstall Products.

3. Inthe Inventory dialog on the Contents tab,
select the OraClient10_home1l checkbox,
where homel can be any text.

4. Click Remove.

5. In the Confirmation dialog, to confirm the
uninstall, click Yes.

6. After the uninstall is complete, to close the
Universal Installer, click Close, then Cancel.

7. Open the Windows Administrative Tools and
select Services.

10.

11.

12.

Select the Distributed Transaction
Coordinator service. If it started, click Stop
to stop it.

From Windows Explorer, delete the
drive_letter:\oracle directory.

From Windows Explorer, delete the
C:\Program Files\Oracle directory.

Run regedit and delete the
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE
key.

Restart the computer.

Installing and configuring the
Oracle 10g Client for Windows

1.

Insert the IMPAX Oracle for Windows 32-bit
DVD.

2. From the DVD drive, run setup.bat.

3. At the Install Oracle "client” or

“server"? prompt, type client.

At the Hostname of the Oracle server
[1 ? prompt, type the correct host name of
the IMPAX Database Server.

. At the What machine is the repository

host? [localhost] prompt, if it is the
localhost, press Enter. Otherwise, specify
the appropriate IP address.

At the Where is the software
repository? prompt, if installing from the
DVD drive on F, press Enter. Otherwise,
type the DVD drive or software repository
directory.

. At the Where is the temporary work

directory? [ C:\cygwin\temp] ? prompt,
click Enter to accept the default location.
Otherwise, type the directory to use.

. After the Oracle installation complete

message appears, restart the server.
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Setting up a connection to the
Oracle database

1.

12.
13.
14.

15.

If the Net Configuration Assistant is not
open, select Start > All Programs >
Oracle - ohome > Configuration and
Migration Tools > Net Configuration
Assistant.

In the Oracle Net Configuration Assistant
Welcome dialog, select Local Net Service
Name configuration and click Next.

If the Naming Methods Configuration dialog
appears, select Local Naming. Click Next.

In the Net Service Name Configuration
screen, select Add. Click Next.

In the Service Name field, type MVF. Click
Next.

From the list of protocols, select TCP. Click
Next.

In the TCP/IP dialog, type the hostname of
the Oracle server.

. Accept the default port number (1521). Click

Next.

. Select Yes, perform a test. Click Next.
10.
11.

Click Change Login.

In the Username field, type mvf, and type
the password for the mvf user.

Click OK.
Click Next.

In the Net Service Name field, ensure that
MVF.world appears. Click Next.

If you do not want to add a net service name
for RIS, select No. Click Next.

or

To add a net service name for RIS, at the
prompt to configure another net service
name, select Yes. Click Next. Then repeat
all previous steps using a different service
name (for example, gprod), as well as a
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different host name, login, and net service
name (for example QPROD.WORLD).

16. In the Net Service Name Configuration
Complete dialog, click Next.

17. In the Naming Methods Configuration
Complete dialog, click Next.

18. To close the Net Configuration Assistant
dialog, click Finish.

Reconfiguring ODBC data source
names

1. Open the Windows Administrative Tools.
Select Data Sources (ODBC).
Switch to the System DSN tab.
Click Add.

In the Create New Data Source dialog, select
Oracle in Oracle_instance_name

Click Finish.

In the Data Source Name field, type mvf.

i A wN

Type a description, if needed.

© © N o

In the TNS Service Name field, type
MVF.world.

10. In the User Name field, type mvf.

11. To save the changes and close the dialog,
click OK.

12. To save the new sources and exit the ODBC
Data Source Administrator dialog, click OK.

13. If reconfiguring the Application Server,
repeat the previous steps for the mvf_ora
DSN as well.

Upgrading to the 10.2.0.4 version
of the Oracle Client for Windows

1. Insert the Oracle on Windows 32-bit DVD.
2. Open a command prompt.

3. Change to the C:\mvf-mig6\bin directory.

4. Type bash upgrade-oracle
location_of_DVD_drive_or
_Oracle_software_repository

5. When you see the message Ready to
upgrade Oracle using repository Oracle
software location. Do you want to
proceed? [y/n], verify that the oracle
software location is correct. If the location
is correct, type y and press Enter.

Upgrading the IMPAX Application
Server software to 6.5.1

1. Insert the IMPAX Business Services CD.

2. Navigate to the CD ROM drive, which
contains the Business Services software.

3. Run AGFA IMPAX Business Services
Setup.exe.

4. Click Install.
5. On the Welcome screen, click Next.

6. On the license agreement screen, select I
accept the terms in the license
agreement. Click Next.

7. On the Web Services Installation Folder
screen, click Change.

8. Set the path to the wwwroot directory so
that it matches the pre-upgrade installation
location. Click OK.

9. Click Next.

10. On the Setup Type screen, select Custom.
Click Next.

11. If you have an IMPAX RIS to connect to,
click RIS Web Services and select This
feature will be installed on local hard
drive.

12. If you are using SmartCard authentication,
verify that NHS SmartCard Web Services
is selected. If it is not selected, select it.
Select This feature will be installed on
local hard drive.

13. Click Next.
14. Click Install.
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15. On the InstallShield Wizard Completed
screen, select Launch IMPAX Business
Services Configuration tool. Click Finish.

16. When the message Previous
configuration found from version
6.X.X... appears, click Yes. This message
is not displayed when upgrading from IMPAX
6.5 to IMPAX 6.5.1.

17. In the Configuration Tool, click Apply.
18. To close the Configuration Tool, click OK.

Installing the IMPAX
documentation

1. Insert the IMPAX Documentation DVD.

2. From the DVD root, double-click
IMPAXDocumentationSetup.exe.

3. On the Welcome screen, click Next.

4. On the Setup Type screen, select the
appropriate option and click Next.

5. If you selected Select Documentation to
Install, on the Choose Features screen, you
can select particular Knowledge Bases or
languages to install.

6. On the Ready to Install the Program screen,
click Install.

7. On the InstallShield Wizard Completed
screen, click Finish.

Running the IMPAX Installation
Server package

1. From the IMPAX Client CD or a network
location, run
IMPAXInstallationServerSetup.exe.

2. On the Welcome to the InstallShield Wizard
for IMPAX Installation Server screen, click
Next.

3. To install the application into
C:\Inetpub\wwwroot\ClientInstaller, on the
Destination Folder screen, click Next.

or
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To install the application to another location,
click Change. In the Change Current
Destination Folder dialog, browse for the
directory location to install into and click
OK. On the Destination Folder screen, click
Next.

4. On the Ready to Install the Program screen,
click Install.

5. On the Installation Wizard Completed
screen, click Finish.

6. On the second Installation Wizard Completed
screen, click Finish.

Running Healthcheck from a URL
to check the status of web
services

1. Ensure that the Healthcheck web.config file
has been configured to the site’s needs.

2. On the Application Server, launch Internet
Explorer.

3. In the address bar, if Healthcheck has not
been configured to automatically log in, type

https:/ /fully_qualified_domain_name/
AgfaHC.Healthcheck.Escrow

or

https:/ /fully_qualified_domain_name/
AgfaHC.Healthcheck.Escrow/
EscrowForm.aspx

4. If Healthcheck has not been configured to
automatically log in, type an IMPAX
Administrator username and password,
select the login domain, and click Log in.

5. To determine what the problem is for any
web services with the status Failed, review
the Comments.

6. To check the status of the web services
again, in Internet Explorer, click Refresh.
Upgrading additional Application
Servers in the cluster

1. Upgrade the IMPAX Application Server
software.

2. Verify the installation.

Upgrading the AD LDS database
from IMPAX 6.5 to IMPAX 6.5.1

Unlike previous versions of the IMPAX Application
Server, the AD LDS database must be migrated
when upgrading from IMPAX 6.5 to 6.5.1. The
migration is performed automatically during the
software upgrade.

Creating a one-time backup of AD
LDS

1. To open an elevated command prompt, click
Start, right-click Command Prompt and
select Run as administrator.

2. At the command prompt, type
dsdbutil
3. At the dsdbutil prompt, type
activate instance AgfaHealthcare
4. At the dsdbutil prompt, type
ifm
5. At the ifm prompt, type
create full Jlocation
6. At the ifm prompt, type
quit
At the dsdbutil prompt, type
quit
Stopping services on the
Application Servers

1. On an Application Server, open the Windows
Administrative Tools and select Services.

2. In the list of services, highlight the World
Wide Web Publishing Service.

3. Click Stop.

4. Repeat steps 2 and 3 for the following
services:
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a. IMPAX Distributed License
Manager

IMPAX Messaging Service
IMPAX App Server Data Manager
IMPAX Audit Event Log Manager
IMPAX Dicom Object Sender
AGFA HealthCare Service
Uninstalling IMPAX 6.3 or later
documentation

1. Open Control Panel.

2. In Windows 2008 Service Pack 2, select
Programs and Features.

-~ 0 2 o T

3. Inthe Programs and Features dialog, under
Currently installed programs, select AGFA
IMPAX version Knowledge Base
buildnumber Documentation.

4. Click Remove.

5. In the confirmation dialog, click OK.

6. Close the Programs and Features dialog.
Uninstalling the IMPAX
Installation Server

1. Open Control Panel.

2. In Windows 2008 Service Pack 2, select
Programs and Features.

3. Select Agfa IMPAX Installation Server
version_number where version_number
is the version of the installed Installation
Server.

4. Right-click and select Uninstall.

Upgrading the IMPAX Application
Server software to 6.5.1

1. Insert the IMPAX Business Services CD.

2. Navigate to the CD ROM drive, which
contains the Business Services software.

3. Click Install.

4. On the Welcome screen, click Next.
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5. On the license agreement screen, select I
accept the terms in the license
agreement. Click Next.

6. On the Web Services Installation Folder
screen, click Change.

7. Set the path to the wwwroot directory so
that it matches the pre-upgrade installation
location. Click OK.

8. Click Next.

9. On the Setup Type screen, select Custom.
Click Next.

10. If you have an IMPAX RIS to connect to,
click RIS Web Services and select This
feature will be installed on local hard
drive.

11. If you are using SmartCard authentication,
verify that NHS SmartCard Web Services
is selected. If it is not selected, select it.
Select This feature will be installed on
local hard drive.

12. Click Next.
13. Click Install.

14. On the InstallShield Wizard Completed
screen, select Launch IMPAX Business
Services Configuration tool. Click Finish.

15. In the Configuration Tool, click Apply.
16. To close the Configuration Tool, click OK.
Installing the IMPAX
documentation
1. Insert the IMPAX Documentation DVD.

2. From the DVD root, double-click
IMPAXDocumentationSetup.exe.

3. On the Welcome screen, click Next.

4. On the Setup Type screen, select the
appropriate option and click Next.

5. If you selected Select Documentation to
Install, on the Choose Features screen, you
can select particular Knowledge Bases or
languages to install.

6. On the Ready to Install the Program screen,
click Install.

7. On the InstallShield Wizard Completed
screen, click Finish.

Running the IMPAX Installation
Server package

1. From the IMPAX Client CD or a network
location, run
IMPAXInstallationServerSetup.exe.

2. On the Welcome to the InstallShield Wizard
for IMPAX Installation Server screen, click
Next.

3. To install the application into
C:\Inetpub\wwwroot\ClientInstaller, on the
Destination Folder screen, click Next.

or

To install the application to another location,
click Change. In the Change Current
Destination Folder dialog, browse for the
directory location to install into and click
OK. On the Destination Folder screen, click
Next.

4. On the Ready to Install the Program screen,
click Install.

5. On the Installation Wizard Completed
screen, click Finish.

6. On the second Installation Wizard Completed
screen, click Finish.

Running Healthcheck from a URL
to check the status of web
services

1. Ensure that the Healthcheck web.config file
has been configured to the site’s needs.

2. On the Application Server, launch Internet
Explorer.

3. In the address bar, if Healthcheck has not
been configured to automatically log in, type

https:/ /fully_qualified_domain_name/
AgfaHC.Healthcheck.Escrow
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or

https:/ /fully_qualified_domain_name/
AgfaHC.Healthcheck.Escrow/
EscrowForm.aspx

4. If Healthcheck has not been configured to
automatically log in, type an IMPAX
Administrator username and password,
select the login domain, and click Log in.

5. To determine what the problem is for any
web services with the status Failed, review
the Comments.

6. To check the status of the web services
again, in Internet Explorer, click Refresh.

Upgrading additional Application
Servers in the cluster

1. Upgrade the IMPAX Application Server
software.

2. Verify the installation.

Migrating an Application Server
from a Windows 2003 server to a
Windows 2008 server

All Application Servers in the same cluster must
be running the same operating system—either
Windows Server 2003 or Windows Server 2008.
When migrating from Windows 2003 to Windows
2008, you must replicate the ADAM data on the
Windows 2003 server to the AD LDS database on
the new Windows 2008 server.

Configuring the Audit Record
Repository database connection

1. On the IMPAX Database Server, open a
command prompt or terminal window.

2. Change to the C:\mvf\bin (AS300) or
/usr/mvf/bin (AS3000, logged in as mvf
user) directory.

3. Type clui.

4. To check if the entry already exists in the
database, type

5. If the entry exists, to update the entry, type

18/ 21



Installing the IMPAX Client

1.

10.
11.

From the IMPAX Client CD or the

IMPAX Client Installation web page
(https://install_server_name/clientinstaller/
language_code), start the IMPAX Client
installation program,
IMPAXClientSetup.exe.

If a File Download dialog appears, click
Open or Run.

If a prompt appears about downloading and
installing missing components, click OK.

Follow the prompts to download and install
Microsoft .NET Framework 3.5, Microsoft
.NET Framework 3.5 SP1, or all.

On the Welcome to the InstallShield Wizard
for IMPAX Client screen, click Next.

On the License Agreement screen, read the
license agreement. If you agree, select I
accept the terms in the license
agreement. Click Next.

To install the application into C:\Program
Files\Agfa\IMPAX Client, on the Destination
Folder screen, click Next.

or

To install the application to another location,
click Change. In the Change Current
Destination Folder dialog, browse for the
directory location to install into and click
OK. On the Destination Folder screen, click
Next.

On the IMPAX Application Server screen, in
the Get or confirm application server name
field, type the fully qualified domain name
of the Application Server to use. Click Next.

On the IMPAX Login Type screen, select the
appropriate authentication method:
Windows, IMPAX, or Smart Card.

Click Next.

On the Ready to Install the Program screen,
click Install.

12.

On the InstallShield Wizard Completed
screen, click Finish.

Restarting antivirus software

1.

On a Windows server where scanning was
stopped, launch the antivirus software.

Start the scan operation according to the
vendor's instructions.

Testing the installed software

1.

On the IMPAX Database Server, run the
Administration Tools and ensure that you
can log in using the administration
password.

On the Application Server, open a web
browser and connect to http://localhost.
Ensure that the “Welcome to IMPAX"” page
is displayed.

Run the IMPAX Client and ensure that you
can log in using the administration
password.

Restarting an archive queue

1.

2.

3.
4.

Log into the IMPAX 6.5.1 Administration
Tools.

On the Daily tab, select Job Manager. 0

In the queue list, select the archive queue.
Click Restart.

Restarting Connectivity Manager
queues

1.

3.

In the Connectivity Manager Service Tools,
click Queue Manager.

In the Queue List table, select the checkbox
beside the queue of any system device or
real world device with a DM Out or
impax_report_server Component.

Click start.
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Taking a post-upgrade system
snapshot

1.

3.

In a command prompt or terminal window,
change to the directory containing the
migration_inventory tool.

On a Windows server, type

migration_inventory -s -d
database_name -U
database_user_name -P
database_password -D
database_server_host_name

On a Solaris server, log in as mvf user and
type

./migration_inventory -s -d
database_name -U
database_user_name -P
database_password -D
database_server_host_name

To create a report file with this information,
in Windows, type

mig_reporter -t system_inventory_tool
In Solaris, type

./mig-reporter -t
system_inventory_tool

Comparing pre- and post-upgrade
snapshots

Open the report file that contains the pre- and
post-upgrade snapshot information. Compare the
pre- and post-upgrade information. Ensure that
all expected studies, objects, stations, and DICOM
printers are still listed.

Synchronizing Windows servers
to an external time source

1.

2.

To open Registry Editor, select Start > Run,
type regedit, and click OK.

To change the synchronization server to
NTP, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
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Parameters\Type subkey, change the
REG_SZ value from NT5DS to NTP.

. To specify if the local machine is a local time
server, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Config\AnnounceFlags subkey, change
the REG_DWORD value to 5.

. To enable the NTPServer, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
TimeProviders\ NtpServer\Enabled
subkey, change the REG_DWORD value to
1.

. To specify where the computer obtains time
stamps, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Parameters\ NtpServer subkey, enter the
list of DNS names or IP addresses.

. To set the poll interval, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
TimeProviders\NtpClient\
SpecialPollInterval subkey, change the
REG_DWORD value to the number of
seconds between each poll.

. To specify the maximum positive difference
that triggers a synchronization, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Config\MaxPosPhaseCorrection subkey,
change the REG_DWORD value to the
maximum number of seconds.

. Similarly, to specify the maximum negative
difference that triggers a synchronization,
inthe HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Config\MaxNegPhaseCorrection subkey,
change the REG_DWORD value to the
maximum number of seconds.

. Exit the Registry Editor.

10.

To stop and restart the Windows Time
server, at a command prompt, type net
stop w32time && net start w32time.

Synchronizing Windows servers
to an internal time source

1.

2.

To open Registry Editor, select Start > Run,
type regedit, and click OK.

To specify if the local machine is a local time
server, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Config\AnnounceFlags subkey, change
REG_DWORD to A.

3. Exit the Registry Editor.
4. To stop and restart the Windows Time

server, at a command prompt, type net
stop w32time && net start w32time.

Synchronizing with a time server
when the IMPAX computer is not
a member of a domain

1. Open Control Panel.

2. Select Date and Time.

3.

4. In the list, type or select the time server to

Switch to the Server Internet Time tab.

synchronize with.

Synchronizing with a time server
when the IMPAX computer is a
member of a domain

1.
2.

3.

4,

Open a command prompt.
Type

w32tm /config /syncfromflags:manual
/manualpeerlist:time_server

To update Windows Time Service to use the
new configuration, type

w32tm /config /update
To synchronize the clock, type

w32tm /resync
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Installing the PSARMT and cache
tools on a Windows server

1.
2.

Insert the IMPAX AS300 CD.

Navigate to the programs\mvf directory and
double-click mvfcachecheck-6.5.0.xx.exe
(cache check and repair tools).

3. On the Welcome screen, click Next.

4. On the Setup Complete screen, click Finish.

6.
7.
8.

Navigate to the programs\mvf directory and
double-click mvfpsarmt-6.5.0.xx.exe
(PSARMT Migration Tools).

On the Welcome screen, click Next.
On the Setup Complete screen, click Finish.
Remove the IMPAX AS300 CD.

Running PSARMT to mark studies
from an external PACS as PACS
archived

1.
2.

Navigate to the C:\mvf directory.

Build the PSARMT database tables by
running build-mvf-psarmt-database.bat.

Install the PSARMT Tools as services by
running install_psarmt.bat.

Specify the migration configuration by
running
mvf_psarmt_config_manager.exe.

Start the PSARMT services by running
start_psarmt.bat.

Perform the migration, based on the
configuration defined in step 4, by running
mvf_psarmt.exe.

Uninstalling the IMPAX Migration
Tools from a Windows computer

1.
2.

Open Control Panel.

On Windows 2003 servers, select Add or
Remove Programs.

On Windows 2008 servers, select Programs
and Features.
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Select IMPAX 6.5.1 AS300 Migration
6.5.0.xxx

On Windows 2003 servers, click
Change/Remove. On Windows 2008
servers, click Uninstall.

In the Confirm File Deletion dialog, click
Yes.

At the Uninstall complete prompt, click
Finish.

Uninstalling the Cross-Cluster
Dictation Interlock tool

1.

On the previous version IMPAX Application
Server where the Cross-Cluster Dictation
Interlock components were installed, open
the Windows Administrative Tools and select
Services.

Right-click the Impax Study Status Relay
service and select Stop.

Close the Services window by selecting File
> Exit.

4. Open a command prompt.

Change to the directory containing the
Cross-Cluster Dictation Interlock
components—possibly C:\Program
Files\Agfa\Impax Business Services.

Type
uninstall_study_status_relay_service.bat.

7. Close the command prompt by typing exit.

8. From Windows Explorer, navigate to and

10.

11.

delete the study-status-signal-relay
folder (possibly from C:\Program
Files\Agfa\Impax Business Services).

On the IMPAX 6.5.1 Application Server
where the 6.5.1 Cross-Cluster Dictation
Interlock components were copied, follow
steps 1 to 7.

Log into a previous version IMPAX Client as
an administrator user.

From the Configure area - Users and Roles
section, delete the remote-dictation user

12.

from the Study Status Relay role, then
delete the Study Status Relay role.

Log into an IMPAX 6.5.1 Client as an
administrator user and repeat the previous
step on it.
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