AS300 Upgrade Tasks Summary—IMPAX 5.2 or 5.3 to IMPAX 6.5.1AGFA &

Running the Cross-Cluster
Dictation Interlock tool

1. On the 6.5.1 Application Server where the
Relay service is running, open a command
prompt.

2. Type the following command:
net start StudyStatusRelayService
3. Exit the command prompt.

Taking a system snapshot

1. At a command prompt, change to the
C:\mvf-mig6\bin directory.

2. Type

migration_inventory -d database_name
-U database_user_name -P
database_password -s -D
database_server_host_name

3. To create a report file with this information,
type
mig_reporter -t system_inventory_tool

Emptying Connectivity Manager
queues

1. In Connectivity Manager, open Service Tools
and click Queue Manager.

2. Select any device with either pending or
error transactions and empty the queues.

3. Retry recent messages and delete older
messages since newer transactions may
have updated patient, study, and report data
after these transactions entered an error
state.

Stopping Connectivity Manager
interfaces

1. In the Connectivity Manager, open Service
Tools.

2. To resort and group all device classes, click
Class.

3. Scroll down to view CMSI and HL7 class
devices.

4. Note which HL7 In and CMSI In interfaces
are started. These interfaces must be
restarted after the IMPAX upgrade.

5. Select the checkbox beside each of the
started inbound interfaces.

6. Click Stop.

Stopping Connectivity Manager
queues

1. In the Connectivity Manager, open Service
Tools and click Queue Manager.

2. Inthe Queue List table, select the checkbox
beside each queue belonging to a device
with a DM Out or impax_report_server
component.

3. Click Stop.

Stop transmitting data to IMPAX

1. Open the Windows Administrative Tools and
select Services.

2. Right-click the DICOM Service Class
Provider service and select Properties.

To change the Service status, click Stop.
From the Startup type list, select Disabled.
To close the Properties dialog, click OK.

A b~ W

Launch the IMPAX Service Tools and log in
as user service.

7. Onthe Daily tab, select Job Manager. D

8. Monitor each Transmit queue and wait for
all outgoing jobs to finish.
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9. Select each Transmit queue and click Halt

Queue. @

10. To confirm that you want to halt the queue,
click Yes.

Redirecting studies to the training
server

Configure modalities to redirect studies to the
training server system, so that they remain
accessible to the IMPAX 6.5.1 Clients while the
migration continues.

Verifying unverified studies

1. In the Service Tools, on the Daily tab, click
Study Manager.

2. From the location list, select Failed
Verification.

3. Set other search criteria to Any value.

4. Click Refresh. %]

5. In the search results, select all studies.
6. To fix up the studies that have failed
HIS verification, click Fix All Studies. I@l

7. Review the results presented in the dialog.

Storing unarchived studies

1. In the Service Tools, on the Daily tab, click
Study Manager.

2. From the location list, select Cached (or
another value that will return the unarchived
studies).

3. Set other search criteria to Any value (or
set to appropriate values).

4. Click Refresh. %]
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8.

In the search results, select the studies to
archive.

Click Store to Archive. Ej:l

To update the status of the selected studies,
click Refresh. C@

Ensure that all studies are archived.

Closing and mirroring archive
volumes

1.

In the Service Tools, on the Setup tab,
select Archive Manager. a

Switch to the Volumes tab.

3. Select a logical volume and click Close

Logical Volume.

If the system has a jukebox archive, you
may have to wait for the sync job to finish.

If the system has a non-jukebox archive, to
ensure that a backup of the data exist,
perform a mirror procedure manually.

On the Daily tab, select Job Manager. 0

Check the Delivery Date Time column for
jobs that are not scheduled to run until later.
If any exist, schedule these jobs to complete
now, using the Set Delivery Date and
Time option at the top.

Emptying all queues

1.

2.

In the Service Tools, on the Daily tab, select
Job Manager. 0

If an archive job remains in any of the
queues, select the job and click Expedite
Selected Job(s). &2

If any other job remains in any of the
queues, select the job and click Delete
selected job(s). Hﬁi

Halting all queues

1.

In the Administration Tools, on the Daily
tab, select Job Manager. 0

2. In the queue list, select All Queues.

3. Click Halt Queue. @

. To confirm that you want to halt the queues,

click Yes.

Deleting cache locations for
studies

1.

No ou ok

On a station with a cache containing
database references to remove, log in as
mvf user and launch CLUI and type the
following:

cache query

. To store all study_refs into variable a, type

save_refs a select distinct ds.study_ref
from dosr_study ds, dosr_object do
where ds.study_ref = do.study_ref and
do.object_ref in (select object_ref from
osr_location where volume_ref =
volume_ref)

. To enter menu mode, type

Go menu

Select Study Manager.

Select Delete Studies Menu.
Select Delete Study from Cache.

To process the study_refs stored in the
variable a, at the command prompt, type a.

Repeat this process on each station in the
cluster that has a cache and whose database
references you want to remove.

Stopping antivirus software

1.

2.

On a Windows server to upgrade, launch the
antivirus software.

Halt the scan operation according to the
vendor's instructions.
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Clearing the archive Logical
Volume

1.

In the Service Tools, on the Setup tab,
select Archive Manager. il

Select the Logical Volume and click Close.

=

3. At the Close Volume prompt, click Yes.

4. Ensure that the Archive queue is halted.

5. Delete the Logical Volume folder and files

from the drive.

Deleting old log files

1.

On the server to be upgraded, open a
command prompt.

2. Change to the C:\mvf\bin\ directory.
3. Run stopall.bat.

4. For future reference, copy all files in

C:\mvf\data\logs\ to a backup location.

. Delete all the log files from

C:\mvf\data\logs.

Removing the IMPAX 5.2 or 5.3
Client Knowledge Base

1.
2.

Open Control Panel.

On Windows 2003 servers, select Add or
Remove Programs.

or

On Windows 2008 servers, click Programs
and Features.

On Windows 2003 servers, select IMPAX
Client Knowledge Base 5.2 or IMPAX
Client Knowledge Base 5.3 and click
Change/Remove.

or

On Windows 2008 servers, select IMPAX
Client Knowledge Base 5.2 or IMPAX
Client Knowledge Base 5.3 and click
Uninstall.
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4. In the Confirmation dialog, click OK.

5. If also uninstalling the IMPAX Server
Knowledge Base, in the Maintenance
Complete dialog, select No, I will restart
my computer later. Otherwise, select Yes,
I want to restart my computer now and
click Finish.

6. If you restarted the computer, log into
Windows as an administrator-level user.

7. To remove any translations of the IMPAX 5.2
or 5.3 Client Knowledge Base, delete the
C:/impax/documents/client/translations
directory.

Removing the IMPAX 5.2 Server
Knowledge Base

1. Open Control Panel.

2. On Windows 2003 servers, select Add or
Remove Programs. On Windows 2008
servers, select Programs and Features.

3. Select IMPAX Server Knowledge Base
5.2.

4. On Windows 2003 servers, click
Change/Remove. On Windows 2008
servers, click Uninstall.

5. In the Confirmation dialog, click OK.

6. In the Maintenance Complete dialog, select
Yes, I want to restart my computer now
and click Finish.

Upgrading to Windows Server
2008

IMPAX 5.2 and 5.3 can be run on the Microsoft
Windows 2000 or Windows Server 2003 operating
systems. When upgrading to IMPAX 6.5.1, you
have the option of staying with Windows Server
2003 or upgrading to Windows Server 2008. If
you are currently running Windows 2000, you
must upgrade to Windows Server 2008. You
cannot stay on Windows 2000.

Microsoft recommends doing a clean installation
of operating systems whenever possible.

Upgrading Windows Server 2008
to Windows Server 2008 SP2

1. Connect to the network or computer where
you want to create the distribution folder.

2. In the shared folder, create a distribution
folder for the service pack.

3. Copy Windows6.0-KB948465-XXX.exe into
the distribution folder.

4. To install the service pack from a remote
shared distribution folder, run
Windows6.0-KB948465-XXX.exe.

5. Follow the instructions in the Setup Wizard.
6. When the installation process is complete,
restart the computer.

Enabling Automatic Updates for
critical Windows XP or 2003
updates

1. Open Control Panel.

2. Select System.

3. Switch to the Automatic Updates tab.
4

. Select Download updates for me, but let
me choose when to install them.

5. To apply the changes, click OK.

6. To verify that the Automatic Updates service
is started, at a command prompt, type net
start.

7. Verify that Automatic Updates is included in
the list of services.

Enabling Automatic Updates in
Windows 2008

Open Control Panel.
Select Windows Update.
Click Change Settings.

A W N =

Select Download updates, but let me
choose whether to install them.

5. To apply the changes, click OK.
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6. If you see the message To check for
updates, you must first install an
update for Windows Update, click Install
now.

7. To verify that the Automatic Updates service
is started, at a command prompt, type net
start.

8. Verify that Automatic Updates is included in
the list of services.

Upgrading to Internet Explorer 7
1. Launch Internet Explorer on a computer
connected to the Internet.
2. Goto

http://www.microsoft.com/windows/
internet-explorer/ie7/

3. From this page, you can either download
Internet Explorer 7 or order it on CD.

4. Once you have obtained the software, run
it on each server that needs upgrading.

5. To install the software, follow the on-screen
prompts.

Enabling remote access to
Knowledge Bases
1. In Internet Explorer, select Tools >
Internet Options.

2. Inthe Internet Options dialog, switch to the
Security tab.

3. Select Trusted sites.
4. Click Sites.

5. In the Trusted sites dialog, if you are
connecting to the Knowledge Base using
http:// rather than https://, clear the
Require server verification (https:) for
all sites in this zone checkbox.

6. In the Add this website to the zone field,
type or paste the name of the Application
Server that the Knowledge Bases are
installed on (https://server_name ).

7. Click Add.
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8. Click Close.
9. Click Custom Level. In the Security

10.

Settings dialog, under Scripting, ensure that
Active scripting is enabled. Click OK.

Click OK.

Enabling local access to
Knowledge Bases

1.

In Internet Explorer, select Tools >
Internet Options.

In the Internet Options dialog, switch to the
Advanced tab.

Under Security, select the Allow active
content from CDs to run on My
Computer and the Allow active content
to run in files on My Computer
checkboxes. Click OK.

For the changes to take effect, close and
restart Internet Explorer.

Upgrading SQL Server 2000 to
SQL Server 2008

1.

3.

On the server you are upgrading, ensure
that the Distributed Transaction Coordinator
service is running:

a. Open the Windows Administrative
Tools and select Services.

b. Select the Distributed Transaction
Coordination service. If this service
is not started, click Start Service.

Ensure that the SQLSERVERAGENT service
is started.

To launch the installer, follow the
instructions supplied with the SQL Server
2008 software.

When prompted, click OK and follow the
on-screen instructions to install the Microsoft
.NET Framework and updated Windows
Installer. You might be asked to restart the
server.

10.

11.

12.

13.

14.

15.

16.

17.

18.

19.

20.

21.

In the SQL Server Installation Center, select
Installation, then select Upgrade from
SQL Server 2000 or SQL Server 2005.

On the Setup Support Rules screen, ensure
that all operations have completed
successfully. Click OK.

On the next screen, enter the product key.
Click Next.

When prompted, accept the Microsoft
Software License Terms. Click Next.

On the Setup Support Files screen, click
Install. After the support files are installed,
click Next.

On the Setup Support Rules screen, ensure
that all operations have completed
successfully. Click Next.

In the Select Instance screen, check that
Instance to Upgrade has been set to
MSSQLSERVER. Click Next.

On the Select Features screen, click Next.

On the Instance Configuration screen, click
Next.

Verify that the disk space requirements have
been met. Click Next.

On the Server Configuration screen, click
Next.

On the Full-text Upgrade screen, keep the
default and click Next.

On the Error and Usage Reporting screen,
click Next.

On the Upgrade Rules screen, check that no
errors appear. Click Next.

On the Ready to Upgrade screen, click
Upgrade.

Verify that the upgrade was successful, then
click Finish and Close.

Restart the computer.
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Stopping SQL Server 2008
services

1.
2.
3.

4.

Open the Windows Administrative Tools.
Select Services.

Select each of the following services in turn
and click Stop Service, if needed:

a. SQL Server Full Text Search

b. SQL Server Full Text Filter Daemon
Launcher

c. SQL Server Browser

d. SQL Server Integration Services
10.0

Close the Services window.

Upgrading SQL Server 2008 to
SQL Server 2008 SP1

1.

> W N

10.

11.

Launch the SP1 installer.
If you see a security warning, click Run.
On the Welcome screen, click Next.

On the License Terms screen, select I
accept the agreement. Click Next.

On the Feature Selection screen, accept the
default selections. Click Next.

On the Check Files in Use screen, wait while
the processes are identified. Then, click
Next, even if some locked files are found.

. On the Ready to Update screen, click

Update.

On the Update Progress screen, wait until
the components are upgraded or installed,
then click Next.

If the Computer Reboot Required prompt
appears, click OK.

On the Installation Complete screen, click
Close.

Restart the computer.
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Upgrading the IMPAX 5.2 or 5.3
database schema to IMPAX 6.5.1

1. On the Database Server, open a command
prompt.

2. Change to the C:\mvf-mig6\bin directory.
3. If upgrading from IMPAX 5.2, type

database-upgrade-script.bat -U sa -P
sapwd -v 52

If upgrading from IMPAX 5.3, type

database-upgrade-script.bat -U sa -P
sapwd -v 53

4. At the prompt

Ready to upgrade database to version
6.5.1. Do you want to proceed [y, n]?

Type y to continue.

5. If prompted for the fully qualified host name
of the login server, type the fully qualified
host name of the Application Server.

6. When prompted for a report source, if the
Connectivity Manager query you ran
previously returned a single value, use that
value as the report source. If the query
returned multiple values for the
requesting_service field, consult a
Connectivity Manager integrator, as
mappings may also need to be changed.

7. Respond appropriately to other prompts that
appear.

Checking the status of SQL Server
upgrades

1. Open the log file called
C:\mvf-mig6\data\logs\
migrate_database_to_IMPAX6.5.1.log

2. If the following warning appears in the log
file, you can safely ignore it:

Warning: The table
"CHANGE_CONTEXT_DETAIL" has been
created but its maximum row size
(8095) exceeds the maximum number of

bytes per row (8060). INSERT or UPDATE
of a row in this table will fail if
the resulting row length exceeds 8060
bytes.

3. Ensure that Migration Complete
Successful appears at the end of the log
file.

Taking the training server offline

1. On the training server system, launch the
Administration Tools and log in as the
service user.

2. On the Daily tab, select Job Manager. O

w

Select All Queues.
Click Halt Queue. @

5. Monitor each Transmit queue and wait for
all outgoing jobs to finish.

b

6. Select each Transmit queue and click Halt
Queue.

7. To confirm that you want to halt the queue,
click Yes.

8. To stop and disable all IMPAX services:
a. Open a command prompt.
b. Change to the C:\mvf\bin\ directory.
c. Type stopall.bat.
d. Type removeall.bat.
e. Exit the command prompt.

9. To prevent Client interaction, open the
Windows Administrative Tools and select
Services. Stop the World Wide Web
Publishing Service (IIS).

Backing up the training server
database

1. Log into the training server as the
AgfaService user.

2. Stop the database by stopping the
OracleServiceMVF Windows Service.
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3. From the
C:\oracle\product\10.2.0\db_1\database
directory, copy the PWDMVF.ora and
spfileMVF.ora to a different system.

4. Determine where the data files are located;
for example, in E:\data\dbase.

5. Copy the entire dbase folder to a different
system.

Migrating worklist and report data

1. On the Application Server, launch the
Migrate training/traveling server data tool
by running the
C:\mvf-mig6\MigrateTRServer\
MigrateTRServer.exe file.

2. If migrating worklist data, select the
Migrate Worklist Data checkbox.

3. If migrating report data, select the Migrate
Report Data checkbox.

4. Under Source, supply the database
information for the training server, as
follows:

a. Click Modify. D

b. In the Data Link Properties dialog,
select Oracle Provider for OLE DB.
Click Next.

c. In the Data Source field, type
mvf_ts.world or the name of the tns
entry in the tnsnames.ora file.

d. Select Use a specific name and
password and type the database user
name—normally dbadmin.

e. Click OK.

f. Inthe Migrate training/traveling server
data dialog, type the database
password.

5. Under Destination, supply the database
information for the production server (the
upgraded IMPAX 6.5.1 server) as follows:

a. Click Modify. D
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6.

b. In the Data Link Properties dialog,
select Microsoft OLE DB Provider
for SQL Server. Click Next.

c. In the Data Source field, type
mvf_ts.world or the name of the tns
entry that was created in
tnsnames.ora.

d. Select Use a specific name and
password and type the database user
name—normally sa.

e. In the Select the database on the
server field, type mvf.

f. Click OK.

g. Inthe Migrate training/traveling server
data dialog, under Destination, type
the database password.

If you have defined Source and Destination
information for worklists and also need to
migrate report data, under Reports, define
the Source and Destination database
information by following step 4 and step 5.

When all appropriate Source and Destination
information is filled in, click Migrate Data.

When the migration is complete, close the
DTSResults dialog.

Uninstalling the previous IMPAX
software packages

1.
2.
3.

Open Control Panel.
Select Add or Remove Programs.

Under Currently installed programs, select
Agfa IMPAX 5.2 version or Agfa
IMPAX 5.3 version .

4. Click Change/Remove.

5. When prompted, type your name (minimum

three characters). Click Next.

6. In the Confirmation dialog, click OK.

7. On the Maintenance Complete screen, click

Finish.

Restart the server.

Determining a password for the
AgfaService account

During the IMPAX Server software installation,
you are prompted to create a password for the
AgfaService account. The password must conform
to the following requirements:

e Be at least eight characters long

¢ Not contain three or more characters from
the user’s account name

e Contain characters from at least three of the
following five categories:

e Uppercase (A to Z)
e Lowercase (a to z)
¢ Digits (0 to 9)

¢ Non-alphanumeric (for example, !, $,
#, or %); avoid commas

e Unicode

Upgrading the IMPAX AS300
32-bit Database Server software

1. Insert the IMPAX AS300 DVD.

2. Navigate to D:\programs\mvf and
double-click as300-installer.exe.

3. Type your name (minimum three
characters).

4. On the Welcome screen, click Next.

5. On the Select features screen, all Default
Packages are selected. Clear the checkboxes
of any packages that should not be installed.

For a single-host server, install all default
packages except, potentially, the MVFocr
package. For a dedicated Database Server,
the MVFNetworkGateway package is not
required, but can be installed.
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10.

11.

12.

13.

14.

15.

16.

Select the Database Packages label.

Clear the Oracle Server Extension
checkbox and select the SQL Server
Extension checkbox.

For a dedicated Database Server (no
archive), or if using PACS Store and
Remember archiving only, clear the Archive
Packages checkbox.

Select the Optional Packages label, then
select the checkboxes of any optional
packages that should be installed.

Click Next.

If a Network Gateway package was installed,
browse to the location of the MVF license
file and click OK.

If an Archive package was installed, browse
to the location of the archive license file and
click OK.

When prompted, type the password for the
AgfaService user.

To confirm that the database is compatible,
click Yes.

On the Ready to begin installation screen,
click Next.

To display the log file for the database
scripts, when prompted, click No.

After all the packages have been installed,
click Yes, I want to restart my computer
now.

Generating the AS300 portable
password file

1.

On the Database Server, open a command
prompt.

2. Change to the C:\mvf\bin\ directory.
3. Type

passkey -M EXPORT -k
temporary_password
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Updating the SQL Server
registration

1.

Select Start > All Programs > Microsoft
SQL Server 2008.

Right-click SQL Server Management
Studio and select Run as.

In the Run as dialog, select The following
user.

From the User name list, select
AgfaService.

In the Password field, type the password for
the AgfaService account and click OK.

Configuring Data Execution
Prevention (DEP)

1.

Right-click Computer and select
Properties.

Under Tasks in the left pane, select
Advanced system settings.

If not selected, switch to the Advanced tab.

Under Performance, click Settings.

5. Switch to the Data Execution Prevention

8.

tab.

In the Performance Options dialog, select
Turn on DEP for all programs and
services except those I select.

For each IMPAX executable in the list that
follows, click Add, navigate to C:\mvf\bin,
select the executable, and click Open:

a. curator.exe
ddo_create.exe
ddo_store.exe
mvf_scp.exe

mvf_scu.exe

-~ 0 a o T

mvf_compressor.exe
g. mvf_autopilot.exe
Click OK and close all open dialogs.

9.

Restart the system.

Backing up the AS300 SQL 2000
database

1.

On the server running the AS300 database,
select Start > All Programs > Microsoft
SQL Server > Enterprise Manager.

2. In the Explorer window of the Enterprise
Manager, expand Console Root >
Microsoft SQL Servers > SQL Server
Group > server > Databases > MVF

3. Select Action > All Tasks > Backup
database.

4. In the SQL Server Backup screen, in the
Backup section, select
Database-complete.

5. Click Add and specify the directory to back
up to.

6. To start the backup, click OK.

7. Exit the SQL Server Enterprise Manager.
Updating the SQL Server
registration

1. Select Start > All Programs > Microsoft
SQL Server 2008.

2. Right-click SQL Server Management
Studio and select Run as.

3. In the Run as dialog, select The following
user.

4. From the User name list, select
AgfaService.

5. Inthe Password field, type the password for

the AgfaService account and click OK.

Restoring the upgraded database
on a new Database Server

1.

Before starting the restore, confirm that the
directory that will contain the mvf database
files has the correct permission:

a. In Windows Explorer, right-click the
folder and select Properties.
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Switch to the Security tab.

Click Edit.

Click Add.

Select ImpaxSQLUser and click OK.

Grant Full Control to ImpaxSQLUser
and click OK.

g. To close the Properties dialog, click
OK.

If you are restoring from tape, insert the
backup tape into the tape drive.

-~ 0 a o T

In the Explorer window of the SQL Server
Management Studio, expand server >
Databases.

Right-click Database and select Restore
Database.

In the Destination for restore section, in the
To database field, type mvf.

In the Source for restore section, select
From device and specify the backup media
and location.

Under Backup set to restore backup set,
select the mvf database backup set.

8. Switch to the Options tab.

9. In the Restore the database files section,

10.

11.

change the location of the data files as
needed.

Select Leave database ready to use by
rolling back uncommitted transactions.
Additional transaction logs cannot be
restored. Click OK.

Create the mvf user login:
a. Open SQL Server Management Studio.
b. Select Server > Security.

c. Right-click Logins and select New
login.

d. In the Login name field, type mvf.

e. Select SQL Server authentication
and in the Password field, type mvf.
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12.

f. Clear the Enforce password policy
checkbox and click OK.

Restore the mvf user permissions:
a. Open SQL Server Management Studio.
b. Open a new query window.

c. Select File > Open and browse to
C:\mvf\etc.

d. Select recreate_user_myvf.sql and
click Open.

e. To execute the script, press F5 or click
Execute.

Upgrading the IMPAX 5.2 or 5.3
database schema to IMPAX 6.5.1

1.

On the Database Server, open a command
prompt.

Change to the C:\mvf-mig6\bin directory.

3. If upgrading from IMPAX 5.2, type

database-upgrade-script.bat -U sa -P
sapwd -v 52

If upgrading from IMPAX 5.3, type

database-upgrade-script.bat -U sa -P
sapwd -v 53

At the prompt

Ready to upgrade database to version
6.5.1. Do you want to proceed [y, n]?

Type y to continue.

If prompted for the fully qualified host name
of the login server, type the fully qualified
host name of the Application Server.

When prompted for a report source, if the
Connectivity Manager query you ran
previously returned a single value, use that
value as the report source. If the query
returned multiple values for the
requesting_service field, consult a
Connectivity Manager integrator, as
mappings may also need to be changed.

7.

Respond appropriately to other prompts that
appear.

Checking the status of SQL Server
upgrades

1.

2.

3.

Open the log file called
C:\mvf-mig6\data\logs\
migrate_database_to_IMPAX6.5.1.log

If the following warning appears in the log
file, you can safely ignore it:

Warning: The table
"CHANGE_CONTEXT_DETAIL" has been
created but its maximum row size
(8095) exceeds the maximum number of
bytes per row (8060). INSERT or UPDATE
of a row in this table will fail if
the resulting row length exceeds 8060
bytes.

Ensure that Migration Complete
Successful appears at the end of the log
file.

Taking the training server offline

1.

> ow

On the training server system, launch the
Administration Tools and log in as the
service user.

On the Daily tab, select Job Manager. O

Select All Queues.

. Click Halt Queue. @

Monitor each Transmit queue and wait for
all outgoing jobs to finish.

. Select each Transmit queue and click Halt

Queue.

. To confirm that you want to halt the queue,

click Yes.

. To stop and disable all IMPAX services:

a. Open a command prompt.
b. Change to the C:\mvf\bin\ directory.
c. Type stopall.bat.
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d. Type removeall.bat.
e. Exit the command prompt.

9. To prevent Client interaction, open the
Windows Administrative Tools and select
Services. Stop the World Wide Web
Publishing Service (1IIS).

Backing up the training server
database

1. Log into the training server as the
AgfaService user.

2. Stop the database by stopping the
OracleServiceMVF Windows Service.

3. From the
C:\oracle\product\10.2.0\db_1\database
directory, copy the PWDMVF.ora and
spfileMVF.ora to a different system.

4. Determine where the data files are located;
for example, in E:\data\dbase.

5. Copy the entire dbase folder to a different
system.

Migrating worklist and report data

1. On the Application Server, launch the
Migrate training/traveling server data tool
by running the
C:\mvf-mig6\MigrateTRServer\
MigrateTRServer.exe file.

2. If migrating worklist data, select the
Migrate Worklist Data checkbox.

3. If migrating report data, select the Migrate
Report Data checkbox.

4. Under Source, supply the database
information for the training server, as
follows:

a. Click Modify. D

b. In the Data Link Properties dialog,
select Oracle Provider for OLE DB.
Click Next.
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5.

6.

c. In the Data Source field, type
mvf_ts.world or the name of the tns
entry in the tnsnames.ora file.

d. Select Use a specific name and
password and type the database user
name—normally dbadmin.

e. Click OK.

f. Inthe Migrate training/traveling server
data dialog, type the database
password.

Under Destination, supply the database
information for the production server (the
upgraded IMPAX 6.5.1 server) as follows:

a. Click Modify. D

b. In the Data Link Properties dialog,
select Microsoft OLE DB Provider
for SQL Server. Click Next.

c. In the Data Source field, type
mvf_ts.world or the name of the tns
entry that was created in
tnsnames.ora.

d. Select Use a specific name and
password and type the database user
name—normally sa.

e. In the Select the database on the
server field, type mvf.

f. Click OK.

g. Inthe Migrate training/traveling server
data dialog, under Destination, type
the database password.

If you have defined Source and Destination
information for worklists and also need to
migrate report data, under Reports, define
the Source and Destination database
information by following step 4 and step 5.

When all appropriate Source and Destination
information is filled in, click Migrate Data.

When the migration is complete, close the
DTSResults dialog.

Generating the AS300 portable
password file

1. On the Database Server, open a command
prompt.

2. Change to the C:\mvf\bin\ directory.
3. Type
passkey -M EXPORT -k
temporary_password
Uninstalling the previous IMPAX
software packages
1. Open Control Panel.
2. Select Add or Remove Programs.

3. Under Currently installed programs, select
Agfa IMPAX 5.2 version or Agfa
IMPAX 5.3 version .

4. Click Change/Remove.

5. When prompted, type your name (minimum
three characters). Click Next.

6. In the Confirmation dialog, click OK.

7. On the Maintenance Complete screen, click
Finish.

8. Restart the server.
Configuring the ODBC connection
to the SQL Database Server

1. On the server to connect, open the Windows
Administrative Tool and select Data
Sources (ODBC).

2. Switch to the System DSN tab.

3. Click Add.

4. Inthe Create New Data Source dialog, select
SQL Server.

5. Click Finish.

6. In the Name field, type mvf.

7. In the Description field, type mvf.

8. In the Server list, type or select the

Database Server name. Click Next.
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10.

11.

12.

13.

14.
15.

16.
17.

18.
19.

20.

21.

22.

23.

If asked whether to overwrite the existing
MVF_SQL, click Yes.

Select the SQL Server Authentication
option.

In the Login ID and Password fields, type
the username and password for the mvf
user.

Click Client Configuration.

In the Add Network Library Configuration
dialog, select TCP/IP. Click OK.

Click Next.

Select the Change the default database
to checkbox.

From the list, select mvf. Click Next.

Clear the Perform translation for
character data checkbox.

Click Finish.

To test the connection, click Test
Connection.

In the ODBC Driver Connect dialog, type the
password for the mvf user and click OK.

When prompted that the connection was
successful, click OK.

To close the Oracle ODBC Driver
Configuration dialog, click OK.

To close the ODBC Data Source
Administrator window, click OK.

Installing the IMPAX 6.5.1 AS300
Network Gateway and Archive
Server packages

1.
2.

Insert the IMPAX AS300 DVD.

Navigate to D:\programs\mvf and
double-click as300-installer.exe.

. Type your name (minimum three

characters).

On the Welcome screen, click Next.
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5. On the Select features screen, all Default
Packages are selected. Clear the checkboxes
of any packages that should not be installed.

6. Clear the Database Packages checkbox.

7. For Archive Servers, select the Archive
Package label. The MVFhsm is the only
archive package listed and is selected by
default. If not using an HSM archive, clear
the MVFhsm checkbox; otherwise, keep it
selected.

For dedicated Network Gateway servers,
clear the Archive Packages checkbox.

8. Select the Optional Packages label.

9. Select any optional packages that should be
installed, and clear the other checkboxes.

10. Click Next.

11. If installing a Network Gateway or Archive
Server/Network Gateway combination,
browse to the location of the MVF license
file and click OK.

12. If installing an Archive Server or Archive
Server/Network Gateway combination,
browse to the location of the MVF archive
license file and click OK.

13. Browse to the location of the portable
password file and click OK.

14. Type the temporary password used to create
the portable password file and click Next.

15. On the Summary screen, click Next.

16. After all the packages have been installed,
click Yes, I want to restart my computer
now.

Installing and configuring Store
and Remember archiving

Some sites may want to have their studies
mirrored at another site through PACS Store and
Remember archiving. This mirroring protects
against loss of data and allows studies from one
PACS to be viewed at another. This can be
achieved effectively using the PACS Archive
Provider (PAP).

For instruction on installing and configuring a
PACS Archive Provider, refer to “Configuring a
PACS Archive Provider (PAP)” (topic number
11586) in the IMPAX 6.5.1 AS300 Installation
and Configuration Guide.

Configuring Data Execution
Prevention (DEP)

1.

Right-click Computer and select
Properties.

Under Tasks in the left pane, select
Advanced system settings.

If not selected, switch to the Advanced tab.

4. Under Performance, click Settings.

5. Switch to the Data Execution Prevention

8.
9.

tab.

In the Performance Options dialog, select
Turn on DEP for all programs and
services except those I select.

For each IMPAX executable in the list that
follows, click Add, navigate to C:\mvf\bin,
select the executable, and click Open:

a. curator.exe
ddo_create.exe
ddo_store.exe
mvf_scp.exe

mvf_scu.exe

-~ 0 Qa o T

mvf_compressor.exe
g. mvf_autopilot.exe
Click OK and close all open dialogs.

Restart the system.

Reconfiguring the Application
Server

1.

Disable the connection to the temporary
IMPAX 6.5.1 database, to the IMPAX 5.2 or
5.3 database and, if applicable, to the
WEB1000 Server.
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Connect to the production IMPAX 6.5.1
database.

Import the portable password file generated
from the production 6.5.1 Database Server.

Set the password and account lockout
policies.

Connect to a non-queryable RIS and remove
an IP address from the IP filtering list.

Perform other Application Server
configurations that could not be completed
during the preparing to upgrade period, such
as managing web services, setting up
Healthcheck, and managing SSL certificates.

Disabling SQL connections

1.

On the Application Server, open the
Windows Administrative Tools and select
Data Sources (ODBC).

2. Switch to the System DSN tab.
3. Select the name of the IMPAX 5.2 or 5.3

database.

4. Click Remove. Confirm the removal.

5. If a connection to the WEB1000 Server was

set up, select the name of that database and
click Remove. Confirm the removal.

6. Click OK.

Connecting to the IMPAX 6.5.1
SQL Server database

1.

On the Application Server, select Start >
All Programs > Agfa Healthcare >
Business Services > Configuration Tool.

In the IMPAX Business Services
Configuration tool, switch to the Database
tab.

Under Database Type, select SQL Server.

4. Under Database Connection Settings, type

the SQL Server Database Server name.
Click Configure ODBC.
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In the ODBC Data Source Administrator
dialog, switch to the System DSN tab.

7. Click Add.
8. In the Create New Data Source dialog, select

10.
11.

12.
13.

14.
15.
16.
17.

18.

19.

20.

21.

22.

23.

24.

25.

26.

SQL Server. Click Finish.

In the Create a New Data Source to SQL
Server dialog, in the Name field, type
mvf_sql.

In the Description field, type mvf.

From the Server list, select the name of the
SQL Server. Click Next.

Click SQL Server Authentication.

Ensure that the Connect to SQL Server to
obtain checkbox is selected.

In the Login ID field, type mvf.
In the Password field, type mvf.
Click Client Configuration.

In the Add Network Library Configuration
dialog, ensure that TCP/IP is selected. Click
OK.

Click Next.

Select the Change the default database
to checkbox.

From the list, ensure that mvf is selected.
Click Next.

Clear the Perform translation for
character data checkbox. Click Finish.

To test the connection, click Test Data
Source.

When prompted that the connection was
successful, click OK.

To close the ODBC Microsoft SQL Server
Setup dialog, click OK.

To close the ODBC Data Source
Administrator dialog, click OK.

In the IMPAX Business Services
Configuration tool, click Test.

27. If the message Connection to SQL Server
database successful appears, click OK.

If the test fails, verify that the SQL Server
Name is correct and test the connection
again.

28. Click Apply.

Importing the portable password
file to the Application Server
1. Select Start > All Programs > Agfa

Healthcare > Business Services >
Configuration Tool.

2. In the IMPAX Business Services
Configuration tool, switch to the Security
tab.

3. Click Import Password.

4. Navigate to the mvf.portable.psd file and
click Open.

5. At the prompt, enter the temporary
password identified when creating the
portable password. Click OK.

6. At the confirmation message, click OK.
7. Click Apply.

Setting the password and account
lockout policies

To perform the user migrations, the password and
account lockout policies were disabled. You can
now reset these according to the site’s IT
department policies.

Connecting the Application Server
to a non-queryable non-IMPAX
RIS

1. Configure the custom RIS mappings in
Connectivity Manager.

2. Open the Business Services Configuration
Tool.

3. Switch to the Web Services tab.

4. In the Report Info Sources area, click Add.
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. To check the value of the requesting_service

field in the Connectivity Manager database,
type
use mcf;

select distinct requesting_service from
mcf_service_request;

In the Edit Report Source dialog, type the
requesting_service value returned in the
previous step into the Report Source
Provider field.

From the RIS Type list, select Connectivity
Manager Non-Queryable RIS. Click OK.

Under Connectivity Manager IP Filtering, in
the Grant Access to IP field, type the IP
address of the Connectivity Manager and
click Add.

. To close the Business Services Configuration

Tool, click OK.

Uninstalling IMPAX 6.5.1 Server

1.

Ensure that the training server (the future
Curator station) is offline.

2. Open Control Panel.

3. Depending on the version of Windows, select

Add or Remove Programs or Programs
and Features.

Under Currently installed programs, select
AGFA IMPAX AS300.

5. Click Change.

6. At the prompt, type your name and click

10.

Next.

. At the Welcome dialog, select Modify. Click

Next.

Clear the checkboxes of all AS300 packages
other than MVFCore, MVFCurator, and
MVFcdexport.

Click Next.

In the Maintenance Complete dialog, select
Yes, I want to restart my computer now
and click Finish.
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11.

If no longer required on this server, you can
also delete any Server license files stored in
the C:\mvf directory.

Uninstalling Oracle on Windows

1.

A U1 A~ W

N

Delete the MVF, or mvf_ora, System Data
Source Name (DSN).

Select Start > Oracle - ohome > Oracle
Installation Products > Universal
Installer.

Click Deinstall Products.
Select ohome and click Remove.
Confirm the removal by clicking Yes.

When the uninstall is complete, to exit out
of the Oracle Universal Installer, click Close,
then Cancel.

Reboot the server.

8. If the Distributed Transaction Coordinator

10.

11.

12.

13.
14.

Service is running, stop it.

If the following directories exist, delete
them.

Run regedit and delete the
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE
key.

Delete all files in the C:\cygwin\tmp
directory.

Delete all files in C:\cygwin\var\tmp
directory.

Delete the C:\installOracleInfo file.
Restart the server.

Configuring the ODBC connection
to the SQL Database Server

1.

On the server to connect, open the Windows
Administrative Tool and select Data
Sources (ODBC).

Switch to the System DSN tab.

3. Click Add.

© N o wuw

10.

11.

12.

13.

14.
15.

16.
17.

18.
19.

20.

21.

22.

23.

In the Create New Data Source dialog, select
SQL Server.

Click Finish.
In the Name field, type mvf.
In the Description field, type mvf.

In the Server list, type or select the
Database Server name. Click Next.

If asked whether to overwrite the existing
MVF_SQL, click Yes.

Select the SQL Server Authentication
option.

In the Login ID and Password fields, type
the username and password for the mvf
user.

Click Client Configuration.

In the Add Network Library Configuration
dialog, select TCP/IP. Click OK.

Click Next.

Select the Change the default database
to checkbox.

From the list, select mvf. Click Next.

Clear the Perform translation for
character data checkbox.

Click Finish.

To test the connection, click Test
Connection.

In the ODBC Driver Connect dialog, type the
password for the mvf user and click OK.

When prompted that the connection was
successful, click OK.

To close the Oracle ODBC Driver
Configuration dialog, click OK.

To close the ODBC Data Source
Administrator window, click OK.

Creating a web cache volume

1.

On the Database Server, log into the
Administration Tools.
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Click Cache Manager. E
Click New Cache Volume. E

Select Web Cache.

5. From the Station list, select the station

where the master curator is installed.

In the Path field, type the path for the new
cache volume.

7. Click Add.
8. In the Warning dialog, verify that the path

is correct and click Yes.

Configuring cache folder
permissions for remote caches
and NAS

1.

2.

3.

On the Database Server, open a command
prompt or terminal window.

Change to the C:\mvf\bin (AS300) or
/usr/mvf/bin/ (AS3000, logged in as root
user) directory.

To obtain the password for the
ImpaxServerUser, type

passkey -M QUERY -u ImpaxServerUser
(AS300) or ./passkey -M QUERY -u
ImpaxServerUser(AS3000)

If the remote web cache is hosted on a
Windows-based system, log into the
machine as an administrator-level user.
Using the built-in Windows 2003 Server
security configuration, create an account for
the ImpaxServerUser that uses the same
password as the account on the Database
Server.

If the web cache is hosted on a
Solaris-based system, install and configure
a subprocess such as NFS or SAMBA.

If an ImpaxServerUser account cannot be
used on the remote cache but rather a
domain user needs to be used, create the
domain user and add this user to the
ImpaxServerGroup on the IMPAX machines
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requiring access (for example, the Curator).
Update the IMPAX services to log in as this
new domain user.

Configuring web cache folder
permissions

1. On the Windows 2003 server hosting the
cache, open Windows Explorer.

2. Navigate to the location of the cache.

w

Right-click the cache folder and select
Sharing and Security.

Select Share this folder.

Type an appropriate Share name.
Click Permissions.

Select Everyone, then click Remove.
Click Add.

In the field for object names, type
Administrators; ImpaxServerGroup, then
click Check Names.
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10. If the names are not found, click Advanced,
then click Find Now. Select the
Administrators and ImpaxServerGroup
accounts and click OK.

11. To close the Select Users or Groups dialog,
click OK.

12. In the Permissions for share_name dialog,
to give each user full read, write, and
execute access to the cache volume folder,
select each user and select Full Control.

13. Close the permissions and properties
dialogs.

To configure web cache folder permissions on Windows
Server 2008

1. On the Windows 2008 server hosting the
cache, open Windows Explorer.

2. Navigate to the location of the cache.

3. Right-click the cache folder and select
Properties.

v © N O 0B

10.

. In the field for object names, type

12.

13.

14.

15.

Switch to the Sharing tab.

Click Advanced Sharing.

Select Share this folder.

Type an appropriate Share name.
Click Permissions.

Select Everyone, then click Remove.
Click Add.

Administrators; ImpaxServerUser, then
click Check Names.

If the names are not found, click Advanced,
then click Find Now. Select the
Administrators and ImpaxServerUser
accounts and click OK.

To close the Select Users or Groups dialog,
click OK.

In the Permissions for share_name dialog,
to give each user full read, write, and
execute access to the cache volume folder,
select each user and select Full Control.

Close the permissions and properties
dialogs.

Preparing studies within a date
range

1.

i A wN

To store all study_refs into variable a, in
CLUI, type

save_refs a select study_ref from
dosr_study where study_date >=
'start_date' and study_date <=
'end_date'

To enter menu mode, type Go menu.
Select 1 for Study Manager.
Select 5 for Prepare Study.

At the prompt for the list of studies to
process, enter a to reference the save_refs
list of studies.
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Preparing studies based on a list
of study references

1. In CLUI, specify the files to prepare with this
command:

study prepare study_ref_1 study_ref_2
.. Study_ref_n
Migrating a cache volume from a
flat to a hierarchical structure

1. At a command prompt on the system where
the cache volume is local, type

cache_migration.exe parameters
(Windows)

or
cache-migration parameters (Solaris,
logged in as mvf user)

Configuring the Audit Record

Repository database connection

1. On the IMPAX Database Server, open a
command prompt or terminal window.

2. Change to the C:\mvf\bin (AS300) or
/usr/mvf/bin (AS3000, logged in as mvf
user) directory.

3. Type clui.

4. To check if the entry already exists in the
database, type

5. If the entry exists, to update the entry, type

Changing the SQL Server
administrator (sa) password

1. On an IMPAX Database Server, log in using
the AgfaService account.

2. Open a command prompt.
3. Change to the C:\mvf\bin directory.

4. To find out what the current sa password is,
type

passkey -M QUERY -u sa -r
c:\mvf\mvf.psd

5. To update the password, type
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6.

sqlcmd -U sa -P password -d master -Q
"sp_password 'old_password',
'new_password', 'sa'"

To log out, type exit.

Synchronizing Windows servers
to an external time source

1.

To open Registry Editor, select Start > Run,
type regedit, and click OK.

To change the synchronization server to
NTP, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Parameters\Type subkey, change the
REG_SZ value from NT5DS to NTP.

. To specify if the local machine is a local time

server, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Config\AnnounceFlags subkey, change
the REG_DWORD value to 5.

To enable the NTPServer, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
TimeProviders\ NtpServer\Enabled
subkey, change the REG_DWORD value to
1.

To specify where the computer obtains time
stamps, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Parameters\ NtpServer subkey, enter the
list of DNS names or IP addresses.

To set the poll interval, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
TimeProviders\NtpClient\
SpecialPollInterval subkey, change the
REG_DWORD value to the number of
seconds between each poll.

To specify the maximum positive difference
that triggers a synchronization, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\

10.

Config\MaxPosPhaseCorrection subkey,
change the REG_DWORD value to the
maximum number of seconds.

Similarly, to specify the maximum negative
difference that triggers a synchronization,
in the HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Config\MaxNegPhaseCorrection subkey,
change the REG_DWORD value to the
maximum number of seconds.

Exit the Registry Editor.

To stop and restart the Windows Time
server, at a command prompt, type net
stop w32time && net start w32time.

Synchronizing Windows servers
to an internal time source

1.

2.

To open Registry Editor, select Start > Run,
type regedit, and click OK.

To specify if the local machine is a local time
server, in the
HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Services\W32Time\
Config\AnnounceFlags subkey, change
REG_DWORD to A.

Exit the Registry Editor.

4. To stop and restart the Windows Time

server, at a command prompt, type net
stop w32time && net start w32time.

Synchronizing with a time server
when the IMPAX computer is not
a member of a domain

1. Open Control Panel.

2. Select Date and Time.

3.

4. In the list, type or select the time server to

Switch to the Server Internet Time tab.

synchronize with.

© Copyright 2011 Agfa HealthCare N.V., Septestraat 27, B-2640, Mortsel, Belgium
14 June 2011

Synchronizing with a time server
when the IMPAX computer is a
member of a domain

1.
2.

3.

4,

Open a command prompt.
Type

w32tm /config /syncfromflags:manual
/manualpeerlist:time_server

To update Windows Time Service to use the
new configuration, type

w32tm /config /update
To synchronize the clock, type

w32tm /resync

Manually uninstalling the
IMPAX 5.2 or 5.3 Client software

1.
2.

Open Control Panel.

On Windows 2003 servers, select Add or
Remove Programs. On Windows 2008
servers, select Programs and Features.

On Windows 2003 servers, under Currently
installed programs, select IMPAX Client ES
and click Remove.

or

On Windows 2008 servers, select IMPAX
Client ES and click Uninstall.

. At the Are you sure you want to remove

this program? prompt, click Yes.

If a Files Not Removed dialog opens, to
remove the remaining files, click Yes.

. At the Uninstall Successful message, click

OK.

7. Restart the computer.

8. After the computer has restarted, verify that

the C:\mvf directory has been deleted. If
the directory is still present, delete it.

Removing the IMPAX 5.2 or 5.3
Client Knowledge Base

1.

Open Control Panel.
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2. On Windows 2003 servers, select Add or

Remove Programs.
or

On Windows 2008 servers, click Programs
and Features.

. On Windows 2003 servers, select IMPAX
Client Knowledge Base 5.2 or IMPAX
Client Knowledge Base 5.3 and click
Change/Remove.

or

On Windows 2008 servers, select IMPAX
Client Knowledge Base 5.2 or IMPAX
Client Knowledge Base 5.3 and click
Uninstall.

. In the Confirmation dialog, click OK.

5. If also uninstalling the IMPAX Server

Knowledge Base, in the Maintenance
Complete dialog, select No, I will restart
my computer later. Otherwise, select Yes,
I want to restart my computer now and
click Finish.

. If you restarted the computer, log into
Windows as an administrator-level user.

. To remove any translations of the IMPAX 5.2
or 5.3 Client Knowledge Base, delete the
C:/impax/documents/client/translations
directory.

Installing the IMPAX Client
1. From the IMPAX Client CD or the

IMPAX Client Installation web page
(https://install_server_name/clientinstaller/
language_code), start the IMPAX Client
installation program,
IMPAXClientSetup.exe.

. If a File Download dialog appears, click
Open or Run.

. If a prompt appears about downloading and
installing missing components, click OK.

. Follow the prompts to download and install
Microsoft .NET Framework 3.5, Microsoft
.NET Framework 3.5 SP1, or all.

5. On the Welcome to the InstallShield Wizard
for IMPAX Client screen, click Next.

6. On the License Agreement screen, read the
license agreement. If you agree, select I
accept the terms in the license
agreement. Click Next.

7. To install the application into C:\Program
Files\Agfa\IMPAX Client, on the Destination
Folder screen, click Next.

or

To install the application to another location,
click Change. In the Change Current
Destination Folder dialog, browse for the
directory location to install into and click
OK. On the Destination Folder screen, click
Next.

8. On the IMPAX Application Server screen, in
the Get or confirm application server name
field, type the fully qualified domain name
of the Application Server to use. Click Next.

9. On the IMPAX Login Type screen, select the
appropriate authentication method:
Windows, IMPAX, or Smart Card.

10. Click Next.

11. Onthe Ready to Install the Program screen,
click Install.

12. On the InstallShield Wizard Completed
screen, click Finish.
Restarting antivirus software

1. On a Windows server where scanning was
stopped, launch the antivirus software.

2. Start the scan operation according to the
vendor’s instructions.

Installing the mvf license key on
a Windows server

1. Match up the correct license key with the
machine’s MAC address.

2. Open Windows Explorer.
3. Copy the license key file to C:\mvf.
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4.

Rename the license key file to mvf.lic.

Installing the archive license key
on a Windows server

1.

Match up the correct license key with the
server’'s MAC address.

2. Open Windows Explorer.

3. Copy the archive license key to the C:\mvf

4.

directory.
Rename the license key to mvfarch.lic.

Testing the installed software

1.

2.

Ensure that the user migration was
successful.

a. On the Application Server, if Windows
2003 is the operating system, select
Start > All Programs > ADAM and
select ADAM ADSI Edit

or

On the Application Server, if Windows
2008 is the operating system, open
the Windows Administrative Tools and
select ADSI Edit.

b. On Windows 2003, right-click ADAM
ADSI Edit and select Connect To. On
Windows 2008, right-click ADSI Edit
and select Connect To.

c. On the Connection Settings screen, fill
in the values as shown in the following
illustration.

d. To close the Connection Settings
dialog, click OK.

e. Expand application server node.
f. Expand distinguished name.

g. Select CN=users.
h.

Verify that the list of original IMPAX
5.2 or 5.3 migrated users is displayed.

Ensure that you can log into the IMPAX 6.5.1
software.
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a. On the IMPAX Database Server, run
the Administration Tools and ensure
that you can log in using the
administration password.

b. On the Application Server, open a web
browser and connect to
http://localhost. Ensure that the
“Welcome to IMPAX"” page is displayed.

c. Run the IMPAX Client and ensure that
you can log in using the administration
password.

3. Test the status of Web Services by running
a Healthcheck.

a. Open a web browser and navigate to
http://application_server_name/
AgfaHC.Healthcheck.Escrow/
AuthenticationForm.aspx.

b. Log in with the administrator user and
password.
Restarting an archive queue

1. Log into the IMPAX 6.5.1 Administration
Tools.

2. On the Daily tab, select Job Manager. 0

3. In the queue list, select the archive queue.
4. Click Restart.

Restarting Connectivity Manager
queues

1. In the Connectivity Manager Service Tools,
click Queue Manager.

2. Inthe Queue List table, select the checkbox
beside the queue of any system device or
real world device with a DM Out or
impax_report_server Component.

3. Click start.

Taking a post-upgrade system
snapshot

1. In a command prompt or terminal window,
change to the directory containing the
migration_inventory tool.

2. On a Windows server, type

migration_inventory -s -d
database_name -U
database_user_name -P
database_password -D
database_server_host_name

On a Solaris server, log in as mvf user and
type

./migration_inventory -s -d
database_name -U
database_user_name -P

database_password -D
database_server_host_name

3. To create a report file with this information,
in Windows, type
mig_reporter -t system_inventory_tool
In Solaris, type
./mig-reporter -t
system_inventory_tool

Comparing pre- and post-upgrade
snapshots

Open the report file that contains the pre- and
post-upgrade snapshot information. Compare the
pre- and post-upgrade information. Ensure that
all expected studies, objects, stations, and DICOM
printers are still listed.

Installing the PSARMT and cache
tools on a Windows server

1. Insert the IMPAX AS300 CD.

2. Navigate to the programs\mvf directory and
double-click mvfcachecheck-6.5.0.xx.exe
(cache check and repair tools).

3. On the Welcome screen, click Next.

4. On the Setup Complete screen, click Finish.
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5. Navigate to the programs\mvf directory and
double-click mvfpsarmt-6.5.0.xx.exe
(PSARMT Migration Tools).

6. On the Welcome screen, click Next.
7. Onthe Setup Complete screen, click Finish.
8. Remove the IMPAX AS300 CD.

Running PSARMT to mark studies
from an external PACS as PACS
archived

1. Navigate to the C:\mvf directory.

2. Build the PSARMT database tables by
running build-mvf-psarmt-database.bat.

3. Install the PSARMT Tools as services by
running install_psarmt.bat.

4. Specify the migration configuration by
running
mvf_psarmt_config_manager.exe.

5. Start the PSARMT services by running
start_psarmt.bat.

6. Perform the migration, based on the
configuration defined in step 4, by running
mvf_psarmt.exe.

Uninstalling the IMPAX Migration
Tools from a Windows computer

1. Open Control Panel.

2. On Windows 2003 servers, select Add or
Remove Programs.

On Windows 2008 servers, select Programs
and Features.

3. Select IMPAX 6.5.1 AS300 Migration
6.5.0.xxx

4. On Windows 2003 servers, click
Change/Remove. On Windows 2008
servers, click Uninstall.

5. In the Confirm File Deletion dialog, click
Yes.

6. At the Uninstall complete prompt, click
Finish.
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Uninstalling the Cross-Cluster
Dictation Interlock tool

1.

On the computer where the 5.2 or 5.3
Cross-Cluster Dictation Interlock
components were copied, open the Windows
Administrative Tools and select Services.

Right-click the MVF Signal Relay service
and select Stop.

Close the Services window by selecting File
> Exit.

4. Open a command prompt.

5. Change to the C:\mvf\bin directory.

6. Type

mvf_signal_relay.exe -remove

7. Type clui.
8. In CLUI, type

10.

11.

12.

13.

14.

15.
16.

delete from map_ini where
ini_section="signal-relay’

Exit CLUI by typing exit.

In Windows Explorer, navigate to C:\mvf\bin
and delete the mvf_signal_relay.exe and
the install_relay-signal.bat files.

Optionally, you can delete the signal-relay
and sig-relay-train users from the

IMPAX 5.2 or 5.3 Service Tools User
Manager.

On the IMPAX 6.5.1 Application Server
where the 6.5.1 Cross-Cluster Dictation
Interlock components were copied, open the
Windows Administrative Tools and select
Services.

Right-click the Impax Study Status Relay
service and select Stop.

Close the Services window by selecting File
> Exit.

Open a command prompt.

Change to the directory containing the
Cross-Cluster Dictation Interlock

17.

18.

19.

20.

21.

components—possibly C:\Program
Files\Agfa\Impax Business Services.

Type
uninstall_study_status_relay_service.bat.
Close the command prompt by typing exit.

From Windows Explorer, navigate to and
delete the study-status-signal-relay
folder (possibly from C:\Program
Files\Agfa\Impax Business Service).

Log into an IMPAX 6.5.1 Client as an
administrator user.

From the Configure area - Users and Roles
section, delete the remote-dictation user
from the Study Status Relay role, then
delete the Study Status Relay role.

Stopping the exhibitSyncNotifier
service

1.

2.

On the AS300 server, navigate to
C:\mvf\sync\bin.

Double-click stopExhbitSyncNotifier.bat.

Uninstalling Data Currency from
an AS300 server

1.

»
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10.

11.

Open the Windows Administrative Tools and
select Services.

Locate the Exhibit PACS Synchronization
Notifier service and stop it.

Exit from the Administrative Tools.

In Windows Explorer, navigate to the
C:\mvf\sync\bin directory.

Run removeSystemDate.bat.
Run removelobQueue.bat.

Run removeSync.bat.

Open Control Panel.

Select Add or Remove Programs.

Under Currently installed programs, select
PACS Synchronization version

Click Change/Remove.
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12. When prompted to confirm the removal,

click Yes.

Removing Client queues from Job
Manager

1. Retrieve the AE_REF of each cached 5.2 or

5.3 Client station. In CLUI, type

select ae_ref from map_ae where
ae_title = 'DISPLAY_STATION_AE'

. Generate a list of cache volumes for that

AE. Type

select * from osr_volume where
volume_type = 'C' and ae_ref =
ae_ref_from_step_1

. To check if any images exist in those caches,

type

select count(*) from osr_location where
volume_ref in
(list_of_volume_refs_from_step_2)

. If the count in step 3 is greater than 0, to

check that those images exist elsewhere in
the system, type

select location_ref from osr_location
oll where volume_ref in
(list_of_volume_refs_from_step_2)

To check that the images do not exist
elsewhere in the system, type

select location_ref from osr_location
ol2 where oll.object_ref =
ol2.object_ref and ol2.volume_ref not
in (list_of_volume_refs_from_step_2)

. If images exist elsewhere in the system,

delete them from this cache. Type

update osr_location set visible = 'F'
where volume_ref in
(list_of_volume_refs_from_step_2)

. Signal the Autopilot and wait until it finishes.

Type
signal WAKE_AUTOPILOT 0 AUTOPILOT

. Repeat the query in step 3 and once it

returns zero, delete the caches. Type
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cache remove volume_ref
8. Delete the services running on this AE. Type
go service
query
delete service_refs_for_AE_title
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